perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: 1.3.5 on windows
Date Thu, 30 Jan 2003 17:01:31 GMT
On Thu, 30 Jan 2003, Radomir Starostik wrote:

> I'd like to run Embperl 1.3.5 with Perl 5.8 on windows. I have
> problem with installation. Can anyone tell me the the versions
> of Apache and mod_perl suitable for it ?

This depends on if you want mod_perl support - mod_perl 1.0 on
Win32 using ActivePerl 8xx doesn't compile, due to the addition
of large_files support. This hasn't been fixed yet, and may not
be for some time, due to the significant performance enhancements
available with mod_perl 2.0 and Apache 2.0 on Win32. mod_perl 2.0
does compile with ActivePerl 8xx, but I'm not sure if Embperl
1.3.5 has been ported to mod_perl 2.0 - Gerald would be better
able to discuss this, as well as the status of Emberl 2 on Win32
with mod_perl 2.0.

If there's interest, I could try making up a ppm package for
HTML-Embperl (and Embperl) without Apache support for ActivePerl
8xx. The HTML-Embperl (and Embperl) packages for builds 6xx (perl
5.6.1) available at http://theoryx5.uwinnipeg.ca/ppmpackages/
both contain two versions of the necessary libraries - one with
Apache support, and the other without. However, these aren't
compatible with ActivePerl 8xx.

-- 
best regards,
randy kobes


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message