perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hoenie Luk <aired...@theearth.com>
Subject Re: $fdat not working when using POST
Date Wed, 29 Jan 2003 06:05:33 GMT
Hi Gerald,

I did what you suggested.

My page has a button named "enter" with value "ENTER WEB SITE". Using POST 
method, I pressed the button and here's the output: (notice $VAR2 at the 
end is empty).

$VAR1 = { 'QUERY_STRING' => '', 'SERVER_ADDR' => '64.71.178.180', 
'HTTP_ACCEPT_LANGUAGE' => 'en-us', 'SERVER_PROTOCOL' => 'HTTP/1.1', 
'HTTP_CONNECTION' => 'Keep-Alive', 'PATH_TRANSLATED' => 
'/home/hoenie/www/bio1a/index.htm', 'REMOTE_PORT' => 10577, 'HTTP_ACCEPT' 
=> 'image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, 
application/vnd.ms-excel, application/vnd.ms-powerpoint, 
application/msword, */*', 'HTTP_USER_AGENT' => 'Mozilla/4.0 (compatible; 
MSIE 6.0; Windows 98; Win 9x 4.90)', 'GATEWAY_INTERFACE' => 'CGI/1.1', 
'HTTP_HOST' => 'hoenie.com', 'PATH_INFO' => '/bio1a/index.htm', 
'SERVER_SOFTWARE' => 'Apache/1.3.26 (Unix) PHP/4.2.2 mod_gzip/1.3.19.1a', 
'SERVER_ADMIN' => 'webmaster@hoenie.com', 'REMOTE_ADDR' => 
'67.120.106.145', 'SCRIPT_NAME' => '/cgi-bin/bio1a/embpcgi.pl', 
'HTTP_ACCEPT_ENCODING' => 'gzip, deflate', 'SERVER_NAME' => 'hoenie.com', 
'DOCUMENT_ROOT' => '/home/hoenie/www/', 'REQUEST_URI' => '/bio1a/', 
'REDIRECT_STATUS' => 200, 'REQUEST_METHOD' => 'GET', 'REDIRECT_URL' => 
'/bio1a/index.htm', 'SCRIPT_FILENAME' => 
'/home/hoenie/cgi-bin/bio1a/embpcgi.pl', 'PATH' => 
'/usr/local/bin:/usr/bin:/bin', 'SERVER_PORT' => 80 }; $VAR2 = {};

         Just to try it out, I changed the method to GET: (notice $VAR2 
does have 'enter' in there).

$VAR1 = { 'QUERY_STRING' => 'enter=ENTER+WEB+SITE', 'SERVER_ADDR' => 
'64.71.178.180', 'HTTP_ACCEPT_LANGUAGE' => 'en-us', 'SERVER_PROTOCOL' => 
'HTTP/1.1', 'HTTP_CONNECTION' => 'Keep-Alive', 'HTTP_REFERER' => 
'http://hoenie.com/bio1a/index.htm', 'PATH_TRANSLATED' => 
'/home/hoenie/www/bio1a/index.htm', 'REMOTE_PORT' => 10555, 
'HTTP_USER_AGENT' => 'Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 
4.90)', 'HTTP_ACCEPT' => 'image/gif, image/x-xbitmap, image/jpeg, 
image/pjpeg, application/vnd.ms-excel, application/vnd.ms-powerpoint, 
application/msword, */*', 'GATEWAY_INTERFACE' => 'CGI/1.1', 'HTTP_HOST' => 
'hoenie.com', 'PATH_INFO' => '/bio1a/index.htm', 'SERVER_SOFTWARE' => 
'Apache/1.3.26 (Unix) PHP/4.2.2 mod_gzip/1.3.19.1a', 'SERVER_ADMIN' => 
'webmaster@hoenie.com', 'REMOTE_ADDR' => '67.120.106.145', 'SCRIPT_NAME' => 
'/cgi-bin/bio1a/embpcgi.pl', 'HTTP_ACCEPT_ENCODING' => 'gzip, deflate', 
'SERVER_NAME' => 'hoenie.com', 'DOCUMENT_ROOT' => '/home/hoenie/www/', 
'REQUEST_URI' => '/bio1a/index.htm?enter=ENTER+WEB+SITE', 'REDIRECT_STATUS' 
=> 200, 'REQUEST_METHOD' => 'GET', 'REDIRECT_URL' => '/bio1a/index.htm', 
'SCRIPT_FILENAME' => '/home/hoenie/cgi-bin/bio1a/embpcgi.pl', 'PATH' => 
'/usr/local/bin:/usr/bin:/bin', 'REDIRECT_QUERY_STRING' => 
'enter=ENTER+WEB+SITE', 'SERVER_PORT' => 80 }; $VAR2 = { 'enter' => 'ENTER 
WEB SITE' }; .

If you want to see it for yourself, go to 
http://hoenie.com/bio1a/index.htm. I leave it in POST method so you can see 
the behavior.

I hope you can figure out why. Thanks very much.

......Hoenie


At 05:39 AM 1/29/2003 +0100, you wrote:


> > This is the setup of my web host.
> >
> > No mod_perl, I'm using embpcgi.pl. Apache 1.3.7 (I think) and Embperl
> > 2.08b. I think these versions are pretty up-to-date.
> >
>
>
>I guess you mean Apache 1.3.27, 1.3.7 would be very old...
>
>Could you try to add the following code to the top of you page, post data to
>it and send me the output
>
>
>[- use Data::Dumper ; -]
>[+ Dumper (\%ENV, \%fdat) -]
>
>Gerald
>
>P.S. Please keep the discussion on the list


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message