perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Hartmaier" <Alexander.Hartma...@t-systems.at>
Subject Re: Embperl on RedHat 8.0
Date Wed, 04 Dec 2002 12:26:13 GMT


Hi!

I've followed the tip mentioned below and it seems to work.
The only problem I've got at the moment is that 'Embperl_UseEnv on' doesn't
work!!!
So my oracle database connection isn't working because the vars ORACLE_HOME and
ORA_NLS33 from httpd.conf aren't used in Embperl.

I can't find anything in the documentation about this.
It's required for embperl 2.x and after migrating from 1.x to 2.x this statement
worked...but not with the cvs version...

What are I'm doing wrong again?

THX Alex





variable@hot.ee (Jaak) am 03.12.2002 14:50:57

An:   embperl@perl.apache.org
Kopie:     (Blindkopie: Alexander Hartmaier/DEBIS/EDVG/AT)

Thema:    Re: Embperl on RedHat 8.0



Hi!

> I found out that I have to install ExtUtils to get the two scripts stated
above
> to work (maybe I need something else but don't know???).
> Because the files have no perl header I have to execute them with 'perl
> xsbuilder/source_scan.pl' and 'perl xsbuilder/xs_generate.pl'.
>
> The last message of the output of xs_generate.pl is:
> Use of uninitialized value in concatenation (.) or string at
> /usr/lib/perl5/site_perl/5.8.0/ExtUtils/XSBuilder/WrapXS.pm line 1177.

I also experienced this warning but I ran xsbuilder/source_scan.pl and
xsbuilder/xs_generate.pl.
under Perl 5.6.1 on another machine and copied those file back.
After that everything works on Perl 5.8.0 / RedHat 8.0.




---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org






---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message