perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Johnson <solut...@gina.net>
Subject Re: Update ...
Date Thu, 19 Dec 2002 17:21:59 GMT
On Thu, 2002-12-19 at 02:51, Rajesh Kumar Mallah. wrote:
> Oh so sorry to hear abt the laptop.
> 
> 
> 
> tell me  one thing , if i want to upgrade to Embperl 2.0b8
> from 1.3.4 what catastrope shud i expect?
> do i have to change by code massively?
> 
> 

In my case I had some very old scripts that used a syntax similar to
this:
[$ foreach @blah $]

Which is not valid under 2.0, in 2.0 you must have the ()s around the
array like standard Perl scripts.

Aaron

> and thanks for the kind reply
> 
> 
> regds
> mallah.
> 
> 
> 
> 
> 
> 
> On Thursday 19 December 2002 12:52 pm, Angus Lees wrote:
> > At Wed, 18 Dec 2002 12:38:37 +0530, Rajesh Kumar Mallah. wrote:
> > > I am using Embperl 1.3.4
> > >
> > > On Tuesday 17 December 2002 09:04 pm, Rajesh Kumar Mallah. wrote:
> > > > [27802]CUP:  Error while closing HTML::Embperl::DOC::_12::LOG: Can't
> > > > locate object method "CLOSE" via package "HTML::Embperl::Log" at
> > > > /opt/perl/lib/site_perl/5.8.0/i686-linux/HTML/Embperl.pm line 1448.
> >
> > Embperl 1.3.4 doesn't work correctly with perl 5.8.  You will need to
> > apply the patch (backported from Embperl2) I posted to this list a
> > month or two ago.
> >
> > (I'd send you the patch myself, but my laptop was stolen along with my
> > copy of that code :(


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message