perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject Re: embperl on cygwin
Date Fri, 06 Dec 2002 08:30:30 GMT
>
> The problem I'm having looks like this.  I'm getting lots of these
warnings comming from perlIO_*.

I don't expect this to be a problem, also it doesn't look nice

>Also, lots of 'undefined reference to <...>' errors.
>

This looks like the ApacheCore.lib is not linked into. Maybe you can check
the linker parameters (as outputed when you run make) and see which lib are
linked.

>
> Also, I've noted that the "-I" flag in all make files is set to 'unix' as
the os... not cygwin.  (e.g.  -I/tmp/apache_1.3.27/src/os/unix).
>

It seems to make sense to change it from unix to cygwin. For a first try
just change it inside of the Makefile.

Makefile.PL checks at it's top if it running under windows. This seems to
fail under cygwin. You can try to set this flag manualy. This may help with
the linker error.

Gerald



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message