perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leideck, Wolfgang" <Wolfgang.Leid...@onsys.de>
Subject Prblems with apache, modperl and embperl
Date Mon, 18 Nov 2002 08:15:45 GMT
Hello,
i'm building a runtime environment for my application with apache-2.0.43, mod_perl-2.0-current
and
embperl-2.0.8b under redhat-linux 7.3.
Here a snipped of httpd.conf:

...
LoadModule perl_module modules/mod_perl.so
PerModule Apache2
LoadModule embperl_module modules/Embperl.so
...
<Directory "path/to/a/directory">
EMBPERL_OPTIONS 16
EMBPERL_APPNAME application
EMBPERL_OBJECT_BASE base.epl
EMBPERL_OBJECT_APP theapp.pl
EMBPERL_OBJECT_FALLBACK notfound.html
<FilesMatch "...">
SetHandler perl-script
PerlHandler Embperl::Object
Options ExecCGI
</FilesMatch>
...
</Directory>

If i want start apache i got following error:
Starting httpd: Syntax error at line ...
Invalid command EMBPERL_OPTIONS ...

I added SetEnv in front of the EMBPERL_... variables and now apache starts. But if i request
a
page under given directory i got an internal server error because "_base.epl" is not found.

I have apache compiled with mod_dso enabled.

What's wrong  here or do i missing something?

Wolfgang

----
Wolfgang Leideck (Serversupport)
ONSYS GmbH   
Rheinuferstr. 9 --- D-67061 Ludwigshafen
Fon: +49 (0)621/60-44103  
Fax: +49 (0)621/60-73744

 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message