perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jochen Topf <joc...@remote.org>
Subject HTML mangling and XML
Date Tue, 19 Nov 2002 09:16:27 GMT
Hi!

I am using Embperl-2.0b8. I am feeding (X)HTML/Emberl-Code through a XSLT
stylesheet. This works well until I have some forms in my HTML code and
Embperl mangels for instance <option> tags by adding a "selected" attribute.
The "selected" is not valid XML so the XSLT parses complains. I tried
setting the optDisable* flags, but it didn't work. Looking at the Changes
file this seems to be normal behaviour for some reason.

The best solution would be if Embperl always produces valid XML in these
cases. This should work with all the old browsers if done properly.

The other solution for me would be to switch of the HTML mangling, but then
I would have to do all the mangling myself.

btw: A very similar problem. In some non-reproducable cases Embperl modified
a URL in a link which contained something like
"http://www.example.org/foo.html?x=y" to
"http://www.example.org/foo.html?x=y&" at which point the XSLT parser
complained because of the unescaped & in there.

Jochen
-- 
Jochen Topf  jochen@remote.org  http://www.remote.org/jochen/  +49-721-388298


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message