perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Saadiq Rodgers-King <saa...@nyc.rr.com>
Subject Re: Embperl returning no data
Date Sat, 16 Nov 2002 00:27:09 GMT
I am using the latest 2.0b9-dev3 from CVS and I'm able to segfault
Apache at will.  I start a single process instance of Apache (httpd -X).
If I hit an html file and then follow that request with an epl file,
that's enough for the segfault.

saadiq@moko:~/dev$wget -S -O /dev/null --cache=off --http-user=user
--http-passwd=pass http://www.site.com/env.epl
--19:12:57--  http://www.site.com/env.epl
           => `/dev/null'
Resolving www.site.com... done.
Connecting to www.site.com[IP]:80... connected.
HTTP request sent, awaiting response...
19:12:57 ERROR -1: No data received.

And then...

root@citrus:/usr/local/src/embperl# httpd -X
Processing config directory: /usr/local/apache/conf/vhosts/
 Processing config file: /usr/local/apache/conf/vhosts/site1
Segmentation fault
root@citrus:/usr/local/src/embperl#

It seems I'm the only one who has this problem.  Is that the case?  If
so, it must be something peculiar to my installation.  I've tried moving
around the AddModule lines in httpd.conf because I recall someone else
on the list solving something else like that.  I've tried removing all
the Embperl files and reinstalling from scratch.  I've tried a few other
page specific things but I'm having no luck.

Any suggestions?  I'm thinking maybe I should try dropping down to
1.3.4.  Any ideas?  Thanks.

Saadiq

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message