perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Zelezny <...@linux.com>
Subject perl 5.8 crash when LC_CTYPE not set.
Date Fri, 18 Oct 2002 11:13:33 GMT
Hi All,

I'm the author of xchat, an irc client that uses Perl embed for scripting. 
Lately I've been getting alot of reports of crashes by users of Perl 5.8.
The solution has always been:

export LC_CTYPE=en_US (en_US or ANY locale really)
xchat &

this avoids the segfault.

Could anyone shed one light on this problem? Is it a perl 5.8 bug?

I don't have 5.8 myself, but others have sent me stack traces something
like this:

Program received signal SIGSEGV, Segmentation fault.
0x080a0830 in Perl_init_stacks ()
(gdb) bt
#0  0x080a0830 in Perl_init_stacks ()
#1  0x0809dc15 in perl_parse ()
#2  0x0809d2f3 in perl_parse ()
#3  0x0809311b in cmd_scpinfo () <- that's my code now.

Another one:

#0  0x0809f060 in S_init_postdump_symbols ()
#1  0x0809c024 in S_parse_body ()
#2  0x0809b6e3 in perl_parse ()
#3  0x08091c2b in perl_init () at perl.c:351 <- my code


All these were solved with the setting of LC_CTYPE env var, but that's
not a good enough solution.

This one appears different, but solved in the same way:

Starting program: /usr/bin/xchat 
[New Thread 1024 (LWP 15105)]
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 15105)]
0x4091f122 in xchat_plugin_init (plugin_handle=0x8214ef8, 
   plugin_name=0x8214f00, plugin_desc=0x8214f04, plugin_version=0x8214f08, 
   arg=0x0) at perl.c:1098
1098  PL_perl_destruct_level = 1;

I wouldn't think the size of the "PL_perl_destruct_level" symbol has
changed or somesuch (ABI change?).

-- 
Peter Zelezny.

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message