perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject Re: Recordset: only one PrimKey field possible?
Date Tue, 29 Oct 2002 07:06:06 GMT
Hi,
> can it possibly be that the !PrimKey directive only works for a
> single field primary key?

Yes

> I tried to do sth. like '!PrimKey'=>'field1, field2',
> 'field1'=>$fdat{val1}, 'field2'=>$fdat{val2} and used
> Recordset->Execute with '=update' directive, but that did not
> work. Then I introduced an id field to the database table and
> changed the code to '!PrimKey'=>'id', 'id'=>$fdat{id} and the
> whole thing worked...
> Is that behaviour expected or do I have some other weird error in
> my code?
>

I never have implement multiple primkeys for performance reason (and I
personaly use them very seldom). You can use when using Update instead of
Execute, where you can pass the fields that are used to select the record as
additional parameter

Gerald



-------------------------------------------------------------
Gerald Richter    ecos electronic communication services gmbh
Internetconnect * Webserver/-design/-datenbanken * Consulting

Post:       Tulpenstrasse 5         D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de         Voice:    +49 6133 925131
WWW:        http://www.ecos.de      Fax:      +49 6133 925152
-------------------------------------------------------------



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message