perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject Re: utf-8 in 1.3.x
Date Thu, 03 Oct 2002 19:24:14 GMT


> At 5:26 AM +0200 9/28/02, Gerald Richter wrote:
> >  > Is there anyway to get proper escaping of strings when I'm using
> >>  UTF-8 encoding?  Right now I print them with my own subroutine which
> >>  sets $escmode to 0 and then escapes <>&.
> >
> >Compiling Embperl with epchar.c.min instead of epchar.c (copy
epchar.c.min
> >to epchar.c) should work with utf8
>
> I wish there were some way to do it in $escmode.  I'm not sure what
> the ramifications of switching all my sites to that would be given
> that many of them don't currently specify any character set.  Any
> ideas?

The effect is, that all characters above 127 are not escaped. This means if
somebody, with a browser with a different default charset then iso-8859-1
will view your site, the characters with code above 127 maybe displayed
wrong. This is mainly a problem for languages like german or french which
uses chars like ä or á .

If you want to be sure that everything is displayed correctly you need to
add the charset definition to your webs

Gerald

-------------------------------------------------------------
Gerald Richter    ecos electronic communication services gmbh
Internetconnect * Webserver/-design/-datenbanken * Consulting

Post:       Tulpenstrasse 5         D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de         Voice:    +49 6133 925131
WWW:        http://www.ecos.de      Fax:      +49 6133 925152
-------------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message