perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Landwehr <andre.landw...@gmx.net>
Subject Re: DBIx::Database problem
Date Tue, 17 Sep 2002 10:51:34 GMT
On Mon, Sep 16, 2002 at 08:39:23PM -0400, Kee Hinckley wrote:
> 	'!DataSource'	=> 'DBI:mysql:memphis_www',
> I'm not sure what the dbname= will do.

I'm not sure either, I copied that part from and old DBI
connection ;-) However, I changed it and it still doesn't work...

Besides: I downloaded the DBIx::Recordset sourcepackage and did a
make test there, no problems at all.

> Here's a typical one from my code.
> 
>     $DB = new DBIx::Database({
>                                 '!DataSource'   => 
>                                 'DBI:mysql:PureMessaging',
>                                 '!Username'     => 'xx',
>                                 '!Password'     => 'xx',
>                                 '!KeepOpen'     => 1,
>                                 '!SaveAs'       => 'PureMessaging',
>                                 '!DBIAttr'      => {PrintError => 0,
>                                                     RaiseError => 1,
>                                                     AutoCommit => 1},
>                             }) || throw PureM::Error::DB($DBI::errstr);

My code now looks pretty much the same now, but still the same
error...

Andre

--
"The inside of a computer is as dumb as hell, but it goes like mad!"
(Physicist Richard Feynman)


Mime
View raw message