perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject Re: Building ssl/mod_perl/apache...
Date Mon, 09 Sep 2002 07:09:11 GMT
Your script looks ok to me. The only thing I do differently is that I pass
the parameters you pass to the Apache conmfigure directly to Makefile.PL of
mod_perl  via APACI_ARGS, eg.

perl Makefile.PL \
          APACHE_SRC=../$apache \
          DO_HTTPD=1 \
          USE_APACI=1 \
          EVERYTHING=1 \
          SSL_BASE=../$openssl \









 APACI_ARGS=--enable-module=ssl --enable-module=auth_db --with-layout=Apache

Now a make will build the final Apache.

You don't need the perl parameters, because they are added by Makefile.PL
itself. If you still get segfaults I would try to compile with fewer
modules, maybe just try only mod_perl + ssl. Maybe with --enable-module=most
you add a module which makes trouble...

Gerald

-------------------------------------------------------------
Gerald Richter    ecos electronic communication services gmbh
Internetconnect * Webserver/-design/-datenbanken * Consulting

Post:       Tulpenstrasse 5         D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de         Voice:    +49 6133 925131
WWW:        http://www.ecos.de      Fax:      +49 6133 925152
-------------------------------------------------------------


----- Original Message -----
From: "Kee Hinckley" <nazgul@somewhere.com>
To: <embperl@perl.apache.org>
Sent: Friday, September 06, 2002 2:27 AM
Subject: Building ssl/mod_perl/apache...


> I've gone over the docs, but for some reason I've just never found
> anything that  just builds mod_ssl, mod_perl and apache all cleanly
> without overwriting each other's config file changes.  Maybe it's
> staring me in the face, but I'm at a loss.
>
> So finally I wrote a script.  Used it on one of my machines and it
> worked like a charm.  Tweaked it for the layout on a new machine
> and....
>
> I'm getting segfaults on mod_perl.  Everything else works just fine.
> In fact, if all I do is copy my old 1.25 (perl 5.6.0) libperl.so into
> the libexec directory, everything works fine with the new software.
> But if I try to move to the new one I've built with this script (perl
> 5.6.1 and mod_perl 1.27) I get segfaults as soon as any embperl sites
> load.  I don't think it's an embperl specific problem, I think it's
> mod_perl, but if anyone has a suggestion on how to prove that, let me
> know.
>
> Here's the script I'm using.  Dinner for two for whoever figures this
> one out for me.
>
> #!/bin/sh
> openssl=openssl-0.9.6e
> apache=apache_1.3.26
> mod_ssl=mod_ssl-2.8.10-1.3.26
> mod_perl=mod_perl-1.27
>
> for dir in $openssl $apache $mod_ssl $mod_perl
> do
>      if [ ! -d "$dir" ]; then
>          echo "$dir doesn't exist."
>          exit 3
>      fi
> done
>
> cd $openssl
> ./Configure
> make
> cd ..
>
> cd $mod_ssl
> SSL_BASE=../$openssl \
>          ./configure --with-apache=../$apache --prefix=/usr/local/apache
> cd ..
>
> cd $mod_perl
> perl Makefile.PL \
>          APACHE_SRC=../$apache \
>          DO_HTTPD=1 \
>          USE_APACI=1 \
>          PREP_HTTPD=1 \
>          EVERYTHING=1
> make
> cd ..
>
> cd $apache
> SSL_BASE=../$openssl ./configure \
>          --enable-module=most \
>          --enable-shared=max \
>          --enable-module=ssl \
>          --enable-module=auth_db \
>          --activate-module=src/modules/perl/libperl.a \
>          --enable-shared=perl \
>          --with-layout=Apache
> make
> cd ..
> --
>
> Kee Hinckley - Somewhere.Com, LLC
> http://consulting.somewhere.com/
>
> I'm not sure which upsets me more: that people are so unwilling to accept
> responsibility for their own actions, or that they are so eager to
regulate
> everyone else's.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
> For additional commands, e-mail: embperl-help@perl.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message