perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject Re: problems with sessions and upgrading
Date Tue, 01 Oct 2002 03:57:17 GMT


> OLD STUFF:  redhat 5.2,  2.0.36 kernel, 1.3.6 apache, 1.21 mod_perl,
> perl 5.005_02, apache session 1.04 and a storable of 0.63, embperl
1.2.b10,
> file system sessions and locking data.
>
> NEW STUFF: redhat 5.2, 2.0.36 kernel, 1.3.26 apache, 1.27 mod_perl,
> perl 5.6.1, apache session 1.54, apache sessionX 2.00b3, storable of
> 2.05, embperl 1.3.4, file system sessions and locking data..
>...

>
> yields the following error message:
>
>               Storable binary image v56.115 more recent than I am (v2.5)
at blib/lib/Storable.pm
> (autosplit into blib/lib/auto/Storable/thaw.al) line 364, <FIL> chunk 1,
at -e line 1
>

Did you try to install the old storable into the new Perl? If this works you
could convert it to some other format (e.g. Data::Dumper), install the new
storeable and put the session data back.

Gerald


-------------------------------------------------------------
Gerald Richter    ecos electronic communication services gmbh
Internetconnect * Webserver/-design/-datenbanken * Consulting

Post:       Tulpenstrasse 5         D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de         Voice:    +49 6133 925131
WWW:        http://www.ecos.de      Fax:      +49 6133 925152
-------------------------------------------------------------



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message