perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leideck, Wolfgang" <Wolfgang.Leid...@onsys.de>
Subject perl-5.8.0 and embperl-2.0b8
Date Wed, 07 Aug 2002 10:00:20 GMT
Hello,
following error occured since i use perl-5.8.0 with embperl-2.0b8:

[28510]ERR: 24: Error in Perl code: (in cleanup) Can't call method "param" on unblessed reference
at /users/apache/htdocs/portal3/main/navbar.epl line 41.

Embperl/2.0b8 Apache/2.0.39 (Unix) mod_perl/1.99_04-dev Perl/v5.8.0 mod_ssl/2.0.39 OpenSSL/0.9.6c
[Wed Aug 7 11:50:20 2002]

Here is the code from navbar.epl:
[$ sub menu $]
[*
   my ($req, $menutab, $idx) = @_;
   my $hashref;
   my $uri = "http://$req->{host}:$req->{port}" . $req->param->uri;
*]

Is there any special with perl-5.8.0 and embperl-2.0b8?

Wolfgang
----
Wolfgang Leideck *** ONSYS GmbH *** Serversupport
Fon: +49 (0)621/60-44103 *** Fax: +49 (0)621/60-73744

 

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message