perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: sessionmanagement with embperl
Date Sat, 06 Jul 2002 20:51:39 GMT
On Sat, 6 Jul 2002, Gerald Richter wrote:

> >Gerald , I downloaded the nmake for the binary package, but nmake  nor
> nmake install
> >will run. I put them under C:/Perl ..which is included in my PATH
> >it says it can,t find such file or directory..but it,s there. what is my
> mistake here?
>
> Try to run it by giving the full path name to the exe file.

Did you get nmake15.exe from
   ftp://ftp.microsoft.com/softlib/mslfiles/
? If so, this is a self-extracting archive - double click
on it, and place the extracted nmake.exe and nmake.err into
your PATH (eg, C:\Perl\bin).

I missed the earlier message - which distribution are you trying
to build? If there's not a ppm package for it, I could see about
making one up.

>
> >I am thinking of starting over from the scratch with active perl ..instead
> of the binary
> >distribution of apache...it becomes very confusing Which version of apache,
> > embperl, modperl and modssl would you recommend for windows.
>
> I recomed ActiveState Perl and source for mod_perl and Apache are described
> in the INSTALL.pod file.
>
> I am not sure if there is a binary package for mod_ssl, because of exports
> restrictions.
>
> >Are there installing instructions for this whole procedure of building up
> and configurating the apache server with >modperl,embperl and modssl from
> the scratch to finish ?
>
> As I already told you in a privious mail, look at the INSTALL.pod file or
> online at http://www.ecos.de/embperl/pod/INSTALL.htm#sect_7
>
> I can't say anything about mod_ssl binary package.

mod_ssl isn't too bad to compile - you have to get and build the
openssl package first. Then get mod_ssl and follow the
instructions for patching the apache sources. Then build and
install Apache (I'm assuming Apache-1.3 here - it's different for
Apache-2). Finally, you'll have to compile mod_perl with EAPI
defined.

best regards,
randy kobes


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message