perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject Re: Problems with EmbperlObject (now with sample source)
Date Mon, 10 Sep 2001 15:20:31 GMT
Hi,

I don't get this error here, could you set EMBPERL_DEBUG to 0xf7c7cfd and
send me the resulting embperl.log file from the requests ?

Gerald


-------------------------------------------------------------
Gerald Richter    ecos electronic communication services gmbh
Internetconnect * Webserver/-design/-datenbanken * Consulting

Post:       Tulpenstrasse 5         D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de         Voice:    +49 6133 925131
WWW:        http://www.ecos.de      Fax:      +49 6133 925152
-------------------------------------------------------------

----- Original Message -----
From: "Rainer Perl" <r.perl@AirCALL.at>
To: "Embperl ML (E-Mail)" <embperl@perl.apache.org>
Sent: Wednesday, September 05, 2001 1:56 PM
Subject: Problems with EmbperlObject (now with sample source)


> Hi again,
>
> while I was trying to track down the problem, I found something else...
have
> a look:
>
> /base.epl:
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <html>
> [- Execute('*'); -]
> </html>
>
> /main.epl:
>
> <body>
> This is the main-file
> <p>
> We're now calling the sub...
> <p>
> [- Execute('sub.epl'); -]
> </body>
>
> /sub.epl:
>
> <p>
> We're now in the sub, and we'll do some tests here...
> [$ if 0 > 1 $]
>  <p>Wow, that's what I call a bug!
> [$ else $]
>  <p>Everything OK
> [$ endif $]
>
> /subdir/main.epl:
>
> [- Execute('../main.epl'); -]
>
> Now, I'm requesting /subdir/main.epl, it gives me:
>
> --snip--
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <html>
> <body>
> This is the main-file
> <p>
> We're now calling the sub...
> <p>
> <p>
> We're now in the sub, and we'll do some tests here...
> <p>Everything OK
>
> </body>
>
> </html>
> --snip--
>
> Ok... and now I'm adding /subdir/sub.epl:
>
> <p>
> This is subdir/sub.epl, I'll now call ../sub.epl...
> [- Execute('../sub.epl'); -]
>
> Again, I'm requesting /subdir/main.epl. But now it gives me:
>
> --snip--
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <html>
> <body>
> This is the main-file
> <p>
> We're now calling the sub...
> <p>
> <p>
> This is subdir/sub.epl, I'll now call ../sub.epl...
> <p>
> We're now in the sub, and we'll do some tests here...
> <p>Wow, th
>
> </body>
>
> </html>
> --snip--
>
> Could someone please try this, to see if it is a bug or just something
with
> my setup...?
>
> Regards,
>
>   Rainer Perl
>
> P.S.: I'm afraid my company's exchange-server will convert this message to
> html - sorry about that, beyond my scope :(
>


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message