perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Wilder" <ste...@matrixInteractive.net>
Subject EMB Perl Seg fault
Date Tue, 06 Feb 2001 12:43:43 GMT

  Hello.  I have Apache 1.3.12, mod_perl 1.25, Embperl 1.3.0, mod_ssl
2.6.6-1.3.12, and
PHP 4.0.4pl1 all compiled statically on a Redhat 6.0 machine, and mySQL
version 3.22.22

  Everything is working okay, except for Embperl.  Whenever I try to connect
to the mySQL database, Apache SEG faults, with no messages in the
embperl.log.

  Here is a stack backtrace from gdb:

(gdb) BT
#0  0x80950c1 in mysql_real_connect (mysql=0x0, host=0x0,
    user=0x85338b0 "www", passwd=0x85338c0 "******",
    db=0x8533e28 "topconlaser", port=0, unix_socket=0x0, client_flag=0)
    at libmysql.c:1147
#1  0x40201f27 in mysql_dr_connect ()
#2  0x40202270 in _MyLogin ()
#3  0x402022df in mysql_db_login ()
#4  0x40205e30 in XS_DBD__mysql__db__login ()
#5  0x823fc36 in Perl_pp_entersub ()
#6  0x8269aad in Perl_runops_standard ()
#7  0x8211f71 in perl_call_sv ()
#8  0x401f2e21 in XS_DBI_dispatch ()
#9  0x823fc36 in Perl_pp_entersub ()
#10 0x8269aad in Perl_runops_standard ()
#11 0x8211f71 in perl_call_sv ()
#12 0x401e335a in EMBPERL_CallCV ()
#13 0x401e386f in EvalAndCall ()
#14 0x401e3a84 in EMBPERL_EvalTransFlags ()
#15 0x401e3acb in EMBPERL_EvalTrans ()
#16 0x401da0b3 in ScanCmdEvals ()
#17 0x401dd6f0 in EMBPERL_ProcessBlock ()
#18 0x401e40d1 in EMBPERL_EvalMain ()
#19 0x401dd3f6 in ProcessFile ()
#20 0x401ddb03 in EMBPERL_ExecuteReq ()
#21 0x401d6763 in XS_HTML__Embperl__Req_ExecuteReq ()
#22 0x823fc36 in Perl_pp_entersub ()
#23 0x8269aad in Perl_runops_standard ()
#24 0x8211f71 in perl_call_sv ()
#25 0x814a62b in perl_call_handler ()
#26 0x8149e3b in perl_run_stacked_handlers ()
#27 0x814832d in perl_handler ()
#28 0x8163d13 in ap_invoke_handler ()
#29 0x81776b9 in process_request_internal ()
#30 0x817771c in ap_process_request ()
#31 0x816ef2e in child_main ()
#32 0x816f0dc in make_child ()
#33 0x816f239 in startup_children ()
#34 0x816f866 in standalone_main ()
#35 0x8170003 in main ()
#36 0x400e7cb3 in __libc_start_main (main=0x816fcac <main>, argc=4,
    argv=0xbffffd44, init=0x8088f24 <_init>, fini=0x8269b8c <_fini>,
    rtld_fini=0x4000a350 <_dl_fini>, stack_end=0xbffffd3c)
    at ../sysdeps/generic/libc-start.c:78
(gdb)

  Any ideas?

Thank you,

Steve Wilder
Matrix Interactive, Inc.
http://www.matrixinteractive.net/
Desk: 248.814.8235
Cell: 248.894.3128
Fax : 248.814.8236


Mime
View raw message