perl-docs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: Cron <perlwww@minotaur> /home/perlwww/apache.org/modperl-docs/bin/site_build_index
Date Mon, 25 Aug 2003 20:24:22 GMT
Bill Moseley wrote:
> On Mon, Aug 25, 2003 at 11:32:40AM -0700, Stas Bekman wrote:
> 
>>Cron Daemon wrote:
>>
>>>err: No unique words indexed!
>>
>>Bill, does it mean that the indexer is not quite working? This is on the 
>>new machine we are moving to: minotaur.apache.org. The old machine and 
>>setup is just fine.
> 
> 
> Hum, looks like the index is being built now.
> 
> bash-2.05b$ hostname
> minotaur.apache.org
> 
> bash-2.05b$ pwd   
> /home/perlwww/apache.org/modperl-docs/dst_html/search
> 
> bash-2.05b$ ls -lt index.swish-e* 
> -rw-rw-r--  1 perlwww  perl  1645372 Aug 25 12:20 index.swish-e.prop
> -rw-rw-r--  1 perlwww  perl  2990232 Aug 25 12:20 index.swish-e
> 
> bash-2.05b$ /home/perlwww/bin/swish-e -T index_header | grep Indexed
> # Indexed on: 2003-08-25 12:20:08 PDT
> 
> It's now 13:16 so it was indexed not too long ago.  (unless those are copied from daedalus).
> 

it's possible that brian was doing some rsyncing while indexing.

> I see that libxml2 is now available on minotaur om /usr/local/lib.  I 
> may update for a newer version of Swish-e and link against that.

we had a problem with that library, and brian has fixed it with a symlink. 
Perhaps it's better to rebuild it from scratch.

On Thu, 21 Aug 2003, Stas Bekman wrote:
 > Brian, is it possible to get libxml2.so.6? I don't have the sources to rebuild
 > swish-e, I should ask Bill to build a new one.
 >
 > /home/perlwww/bin> ./swish-e
 > /usr/libexec/ld-elf.so.1: Shared object "libxml2.so.6" not found
 > /home/perlwww/bin> locate libxml2.so.6
 > /home/perlwww/bin> locate libxml2.so
 > /usr/local/lib/libxml2.so
 > /usr/local/lib/libxml2.so.5

I wish I understood how the numbering scheme for shared objects worked, or
why they're constantly non-standard.  I do have the latest libxml2 port
installed, at least I think I do, yet it creates and installs
libxml2.so.5.  Looks like moseley's build on daedalus of libxml2 is
of libxml2 2.4.23, which is older than the one we've got on daedalus,
which is 2.5.10, yet it creates a libxml2.so.6.  So, figuring the
difference really doesn't matter, I've copied /usr/local/lib/libxml2.so.5
to /usr/local/lib/libxml2.so.6.  See if it works.  If not we should just
get Bill onto minotaur to do a build.  I could also install the swish-e
port on minotaur, that's at 2.2.2.


---------------------------------------------------------------------
To unsubscribe, e-mail: docs-dev-unsubscribe@perl.apache.org
For additional commands, e-mail: docs-dev-help@perl.apache.org


Mime
View raw message