perl-docs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Moseley <mose...@hank.org>
Subject Re: Cron <perlwww@minotaur> /home/perlwww/apache.org/modperl-docs/bin/site_build_index
Date Mon, 25 Aug 2003 21:31:42 GMT
On Mon, Aug 25, 2003 at 01:24:22PM -0700, Stas Bekman wrote:

> >It's now 13:16 so it was indexed not too long ago.  (unless those are 
> >copied from daedalus).
> >
> 
> it's possible that brian was doing some rsyncing while indexing.

so you think that might of caused a problem with the indexing, or are 
you saying that the index files might be synced from daedalus and that 
it's still not building correctly on minotaur?  In other words, indexing 
is running ok now?

BTW:  Should group perl have write perms?

bash-2.05b$ groups
moseley perlwww apcvs perl apsearch

bash-2.05b$ pwd
/home/perlwww/apache.org/modperl-docs/dst_html/search

bash-2.05b$ touch foo
touch: foo: Permission denied

bash-2.05b$ ls -ld ..
drwxr-xr-x  16 perlwww  perl  1024 Aug 14 19:48 ..



> >I see that libxml2 is now available on minotaur om /usr/local/lib.  I 
> >may update for a newer version of Swish-e and link against that.

Notes below:

> 
> we had a problem with that library, and brian has fixed it with a symlink. 
> Perhaps it's better to rebuild it from scratch.
> 
> On Thu, 21 Aug 2003, Stas Bekman wrote:
> > Brian, is it possible to get libxml2.so.6? I don't have the sources to 
> rebuild
> > swish-e, I should ask Bill to build a new one.
> >
> > /home/perlwww/bin> ./swish-e
> > /usr/libexec/ld-elf.so.1: Shared object "libxml2.so.6" not found
> > /home/perlwww/bin> locate libxml2.so.6
> > /home/perlwww/bin> locate libxml2.so
> > /usr/local/lib/libxml2.so
> > /usr/local/lib/libxml2.so.5

That was on minotaur?

That swish-e binary I built has a runtime path compiled in to look in 
/home/moseley/local/lib.  I forget how to print this path out but I 
guess this works:

bash-2.05b$ strings  /home/perlwww/bin/swish-e | grep moseley
/home/moseley/local/lib

So the contents of my home directory didn't get copied (where it's 
looking for libxml2).

bash-2.05b$ ls /home/moseley/local/lib
ls: /home/moseley/local/lib: No such file or directory


> I wish I understood how the numbering scheme for shared objects worked, or
> why they're constantly non-standard.  I do have the latest libxml2 port
> installed, at least I think I do, yet it creates and installs
> libxml2.so.5.  Looks like moseley's build on daedalus of libxml2 is
> of libxml2 2.4.23, which is older than the one we've got on daedalus,
> which is 2.5.10, yet it creates a libxml2.so.6.  So, figuring the
> difference really doesn't matter, I've copied /usr/local/lib/libxml2.so.5
> to /usr/local/lib/libxml2.so.6.  See if it works.  If not we should just
> get Bill onto minotaur to do a build.  I could also install the swish-e
> port on minotaur, that's at 2.2.2.

Library version number are odd.  They are not suppose to match program 
version, of course.

Swish 2.4.0 is about to be released with a number of changes -- mostly 
the configure script updates paths to modules and helper programs 
(instead of having to set @INC manually).  Perl modules get installed in 
$libexecdir/swish-e/perl as they are really just helper modules for 
programs specific to swish-e, and that allows different versions of 
swish on the same machine (by using different prefixes).

2.4.0 is just waiting for some Windows issues to be solved.  So if we 
need to rebuild swish I'd like to upgrade, too.


-- 
Bill Moseley
moseley@hank.org


---------------------------------------------------------------------
To unsubscribe, e-mail: docs-dev-unsubscribe@perl.apache.org
For additional commands, e-mail: docs-dev-help@perl.apache.org


Mime
View raw message