perl-docs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Per Einar Ellefsen <per.ei...@skynet.be>
Subject Re: build errors
Date Thu, 28 Mar 2002 19:01:53 GMT
At 02:40 28.03.2002, Stas Bekman wrote:
>Per Einar Ellefsen wrote:
>>Hi all,
>>I'm running Cygwin under Windows XP. Wanting to build the site, I got 
>>DocSet and all its prerequisites (btw Stas, you need to update the 
>>README, it doesn't state Template and Pod::POM as prereqs).
>
>No, these are the prerequisites of DocSet, I cannot recursively list all 
>the prerequisites. When you run 'perl Makefile.PL' it checks the 
>prerequisites and reports misses. Does it for you?

Well, I was talking about the DocSet package :)
Anyway, no problem, it listed the prerequisites I needed when I ran `perl 
Makefile.PL`


>>But I'm having some big problems:
>>running:
>>$ bin/build
>>I get this output:
>>html2ps: Command not found. (is this a problem ?)
>
>you won't be able to build the pdfs without this (which is needed when you 
>use -d flag to bin/build). It goes like this:
>
>DocSet installs html2ps, then when it's run it checks whether it has 
>html2ps by calling system('which html2ps'). Now I've no idea whether 
>which() works on non-Unix systems. Please look at the 
>lib/DocSet/RunTime.pm and see if there is a better crossplatform solution 
>for checking whether some executable is available.

Wow, weird. When I run which html2ps, I get "html2ps: Command not found" 
However, html2ps is installed, and I can run it. Very weird. Must be a 
cygwin bug, and I can't reproduce it with anything else.
Anyway, this isn't your problem, and it doesn't matter so much to me if I 
don't get the PDF versions.

Concerning which: I'm not running this straight on Win32, I'm running it 
under cygwin, a Unix emulation layer, so it's closer to Unix. which clearly 
doesn't work on Win32, and I didn't even want to try running DocSet on 
stock Win32, as I'd probably run into a lot of obscure errors (like not 
even being able to run bin/build because it uses the "env" command which 
isn't available on Win32). I don't know about any cross-platform module, 
the only way I can think of is just to emulate the whole thing in Perl. Is 
it worth it? Should I try and get DocSet working on standard Win32?

>Next step it checks whether you have ps2pdf(1) which is needed to convert 
>PS files to PDFs. It uses the same technique.

I've got that one too, but as it doesn't find html2ps using which, there's 
no point in this :)


>>----------------------------------------
>>File: 
>>/cygdrive/d/users/pereinar/mod-perl/modperl-docs/src/maillist/email-etiquette.pod

>>
>>spurious '>' at <input text> line 11
>>spurious '>' at <input text> line 400
>>spurious '>' at <input text> line 400
>>spurious '>' at <input text> line 400
>>spurious '>' at <input text> line 404
>>----------------------------------------
>>File: 
>>/cygdrive/d/users/pereinar/mod-perl/modperl-docs/src/docs/1.0/guide/intro.pod
>>spurious '>' at <input text> line 66
>>spurious '>' at <input text> line 71
>
>This is a bad POD, I'll fix those. (unescaped '>' and '<')
>
>>...
>>Actually, it seems like it barks at all the HTML tags in the =for html 
>>POD parts.
>>I'm not sure why it's complaining about this, as I know they're supposed 
>>to be there.
>
>see above
>No, actually this is not a bad POD, as you said the first one is inside 
>html block so any mark up should be ignored.
>The second is code block and the same should apply. I don't get these 
>problems reported, do you run the latest Pod::POM?
>v0.15?

Yes, I have Pod::POM v. 0.15. Didn't show up using $Pod::POM::VERSION, but 
I checked the build directory, and it said 0.15 in it. I installed it 
directyl with the CPAN shell yesterday, so it should be the latest.



>>I get my dst_html directory, but all the pages generated from POD files 
>>don't appear, not even their titles.
>>So.. problem..
>
>none of the problems you've mentioned so far, should be a critical problem 
>for getting the basic site build.

Well the basic site is built. But as I mentioned, I get:
- all documents created from POD sources are empty
- no titles or descriptions on the pages listing these documents.

This is very weird, and I can only assume it's caused by some malfunction 
of the interpretation of the POD documents.


>>Anyone know what is causing this?
>
>DocSet was developed on Linux and tested on a few Unix platforms.
>It's quite possible that some tweaks are needed for other platforms,
>but you will need to help me here.

If I found out what was wrong, I would :) Anyway, as I said above, Cygwin 
is pretty close to Unix...


>The verbose mode shows almost everything the DocSet does, so simple add -v 
>flag:
>
>   bin/build -vf
>
>see what it attempts to do and check that it actually does this. Could be 
>that more checks need to be added. If all this doesn't help, try to work 
>with the perl debugger.

Well, everything seems pretty normal to me... I'm not sure what is supposed 
to happen, but I get for example this on the Downloads part:
####################################
### [scan] HTML DocSet: Download ###
####################################
+++ Reading cache from 
/cygdrive/d/users/pereinar/mod-perl/modperl-docs/src/download/cache.html.dat
+++ source.pod: processing (not modified / forced)
+++ Scanning source.pod
+++ binaries.pod: processing (not modified / forced)
+++ Scanning binaries.pod
+++ bundles.html: processing (not modified / forced)
+++ Scanning bundles.html
+++ Storing the docset's cache to 
/cygdrive/d/users/pereinar/mod-perl/modperl-docs/src/download/cache.html.dat

I'll maybe have to try with the pelr debugger, yes...


>I really hope that it won't be hard to make it work on non-Unix platforms.
>
>p.s. I'm leaving for a long weekend today, so may be others will be able 
>to help here while I'm away.




-- 
Per Einar Ellefsen
per.einar@skynet.be


---------------------------------------------------------------------
To unsubscribe, e-mail: docs-dev-unsubscribe@perl.apache.org
For additional commands, e-mail: docs-dev-help@perl.apache.org


Mime
View raw message