perl-docs-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ran...@apache.org
Subject svn commit: r629669 - /perl/modperl/docs/trunk/src/docs/2.0/os/win32/install.pod
Date Thu, 21 Feb 2008 01:46:52 GMT
Author: randyk
Date: Wed Feb 20 17:46:50 2008
New Revision: 629669

URL: http://svn.apache.org/viewvc?rev=629669&view=rev
Log:
add mention of existence of a mod_perl ppm packages for Win32 ActivePerl 10xx.

Modified:
    perl/modperl/docs/trunk/src/docs/2.0/os/win32/install.pod

Modified: perl/modperl/docs/trunk/src/docs/2.0/os/win32/install.pod
URL: http://svn.apache.org/viewvc/perl/modperl/docs/trunk/src/docs/2.0/os/win32/install.pod?rev=629669&r1=629668&r2=629669&view=diff
==============================================================================
--- perl/modperl/docs/trunk/src/docs/2.0/os/win32/install.pod (original)
+++ perl/modperl/docs/trunk/src/docs/2.0/os/win32/install.pod Wed Feb 20 17:46:50 2008
@@ -146,8 +146,8 @@
        http://theoryx5.uwinnipeg.ca/ppms/mod_perl-2.0.ppd
 
 for Apache/2.0. Another way, which will be useful if you plan on 
-installing additional Apache modules, is to set the repository
-within the C<ppm> shell utility to
+installing additional Apache modules, is to add the following
+repository within C<ppm>:
 
    http://theoryx5.uwinnipeg.ca/ppms/
 
@@ -156,8 +156,9 @@
    http://theoryx5.uwinnipeg.ca/cgi-bin/ppmserver?urn:/PPMServer58
 
 for ActivePerl 818 or lower;
-see the help utility within the C<ppm> shell for
-details. mod_perl 2.0 can then be installed, within the ppm shell, as 
+see the help utility within C<ppm> for
+details on how to do this. 
+mod_perl 2.0 can then be installed, within the ppm shell, as 
 
   ppm> install mod_perl
 
@@ -170,6 +171,27 @@
 F<Apache> directory from mod_perl 1.0. See the section below on
 configuring mod_perl to add this directory to the C<@INC> path for
 searching for modules.
+
+The preceding L<http://theoryx5.uwinnipeg.ca/ppms/> repository
+is appropriate for ActivePerl 8xx builds, based on perl-5.8.
+If you're using an ActivePerl 10xx build, based on perl-5.10,
+you can install mod_perl via
+
+ C:\> ppm install
+       http://cpan.uwinnipeg.ca/PPMPackages/10xx/mod_perl.ppd
+
+for Apache/2.2. The corresponding repository that can be
+added to ppm is
+
+   http://cpan.uwinnipeg.ca/PPMPackages/10xx/
+
+after which mod_perl can be installed as
+
+  ppm> install mod_perl
+
+Note that ActivePerl 8xx and ActivePerl 10xx are not binary
+compatible, which means ppm packages compiled, for example,
+for an 8xx build are not compatible with ActivePerl 10xx.
 
 The mod_perl PPM package also includes the necessary Apache DLL
 F<mod_perl.so>; a post-installation script should be run which will



---------------------------------------------------------------------
To unsubscribe, e-mail: docs-cvs-unsubscribe@perl.apache.org
For additional commands, e-mail: docs-cvs-help@perl.apache.org


Mime
View raw message