perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Hay <steve.m....@googlemail.com>
Subject Re: [RELEASE CANDIDATE]: mod_perl-2.0.9 RC1
Date Wed, 27 May 2015 22:33:43 GMT
On 27 May 2015 21:50, "Gregg Smith" <modsdev@gmail.com> wrote:
>
> Hi,
>
> Apache 2.4.12 Perl 5.16.2 VC++ 2008
>
> Build went fine but 'nmake test' gives me;
>
>         C:\usr\bin\perl.exe -Iblib\arch -Iblib\lib  t/TEST -clean
>           C:\usr\bin\perl.exe -Iblib\arch -Iblib\lib  t/TEST -bugreport
-verbose=0
> C:\Apache24\bin\httpd.exe  -d C:/build4/mod_perl-2.0.9-rc1/t -f
C:/build4/mod_perl-2.0.9-rc1/t/conf/
> httpd.conf -D APACHE2 -D APACHE2_4 -D PERL_USEITHREADS
> using Apache/2.4.12 (winnt MPM)
>
> waiting 300 seconds for server to start: ...[Wed May 27 13:25:18.706600
2015] [env:warn] [pid 3524:t
> id 292] AH01506: PassEnv variable LD_LIBRARY_PATH was undefined
> AH00526: Syntax error on line 2006 of
C:/build4/mod_perl-2.0.9-rc1/t/conf/httpd.conf:
> Invalid command 'Order', perhaps misspelled or defined by a module not
included in the server config
> uration
>
> 'Order' ... that would be alright if mod_access_compat.so would also get
loaded, but obviously it doesn't.
>
> I also see this is the generated httpd.conf
> <IfModule mod_version.c>
> <IfVersion > 2.4.1>
>
> That would be fine if it would load mod_version, but doesn't.
>
> I'm sure this is somehow my fault.  Steve, how did you test this on
Apache 2.4 Win32?

Is it a new, clean build of Apache? I think the generated httpd.conf is
influenced by what's in the httpd.conf of the Apache you build against...

I used a new Apache and all was well with 2.4. With 2.2 I had to edit the
httpd.conf of my Apache installation (even though it was a fresh build
again) in order to enable all the LoadModule lines, otherwise something was
missing since not everything is enabled by default with 2.2 even though all
modules are built ...

Coming to think of it, it might have been mod_version that was the problem,
but a new build of 2.4 does have it enabled already (at least, when
building with all modules enabled).

Steve

>
> Regards,
>
> Gregg
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
> For additional commands, e-mail: dev-help@perl.apache.org
>

Mime
View raw message