perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@redhotpenguin.com>
Subject Back at testing 2.0.9-dev with httpd 2.4.12
Date Wed, 25 Mar 2015 05:52:53 GMT
Here's my latest results from testing 2.0.9-dev with httpd 2.4.12 on
OS X 10.10.2

Configured httpd with:

./configure --prefix=$HOME/dev/httpd_24 --with-included_apr --with-mpm=prefork

By default httpd 2.4 builds with the event MPM I found.

I built mod_perl with:

perl Makefile.PL MP_NO_THREADS=1

The build is successful, but for some reason the
_mod_perl_handler_name symbol can't be found during make test. Will
dig into it, any pointers appreciated.

/Users/phred/dev/httpd_24/bin/httpd  -d
/Users/phred/dev/modperl/mod_perl-2.0/t -f
/Users/phred/dev/modperl/mod_perl-2.0/t/conf/httpd.conf -D APACHE2
using Apache/2.4.12 (prefork MPM)
waiting 300 seconds for server to start: 00:00httpd: Syntax error on
line 82 of /Users/phred/dev/modperl/mod_perl-2.0/t/conf/httpd.conf:
Cannot load /Users/phred/dev/modperl/mod_perl-2.0/src/modules/perl/mod_perl.so
into server: dlopen(/Users/phred/dev/modperl/mod_perl-2.0/src/modules/perl/mod_perl.so,
10): Symbol not found: _modperl_handler_name\n  Referenced from:
/Users/phred/dev/modperl/mod_perl-2.0/src/modules/perl/mod_perl.so\n
Expected in: dynamic lookup\n
waiting 300 seconds for server to start: 00:45^C

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message