perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Kalu┼ża <jkal...@redhat.com>
Subject Re: test failure in svn head
Date Wed, 11 Mar 2015 08:13:57 GMT
On 02/03/2015 09:19 AM, Steve Hay wrote:
> On 28 January 2015 at 01:33, Steve Hay <steve.m.hay@googlemail.com> wrote:
>> On 26 January 2015 at 09:21, Steve Hay <steve.m.hay@googlemail.com> wrote:
>>> On 25 January 2015 at 19:41, Steve Hay <steve.m.hay@googlemail.com> wrote:
>>>> On 24 January 2015 at 04:32, Fred Moyer <fred@redhotpenguin.com> wrote:
>>>>> Ran across a test failure while trying to roll RC1 today. Any thoughts?
>>>>>
>>>>> perl 5.14.2, httpd 2.4.6
>>>>>
>>>>> fred@dev ~/dev/mod_perl-2.0 $ uname -r
>>>>> 2.6.32-220.23.1.el6.x86_64
>>>>>
>>>>> Built via:
>>>>>
>>>>> perl Makefile.PL MP_APXS=/home/fred/dev/httpd24/bin/apxs MP_NO_THREADS=1
>>>>>
>>>>> Build succeeded, but got a test failure on test startup.
>>>>>
>>>>> fred@dev ~/dev/mod_perl-2.0 $ tail -f t/logs/error_log
>>>>> [Fri Jan 23 14:26:30.719260 2015] [perl:error] [pid 93630] Can't
>>>>> locate object method "loglevel" via package "Apache2::ServerRec" at
>>>>> /home/fred/dev/mod_perl-2.0/t/conf/post_config_startup.pl line
>>>>> 82.\nCompilation failed in require at (eval 197) line 1.\n
>>>>> [Fri Jan 23 14:26:30.719295 2015] [perl:error] [pid 93630] Can't load
>>>>> Perl file: /home/fred/dev/mod_perl-2.0/t/conf/post_config_startup.pl
>>>>> for server localhost:8529, exiting...
>>>>>
>>>>
>>>> I haven't tried building for a while, and just assumed that things
>>>> were good to go since I didn't think there had been any changes
>>>> lately, but I was wrong.
>>>>
>>>> My build fails with httpd-2.4.9:
>>>>
>>>> ConnectionUtil.obj : error LNK2001: unresolved external symbol
>>>> _modperl_pnotes_kill
>>>> ..\..\..\blib\arch\auto\Apache2\ConnectionUtil\ConnectionUtil.dll : fatal
error
>>>>
>>>> Reverting this commit:
>>>>
>>>> http://svn.apache.org/viewvc?view=revision&revision=1638351
>>>>
>>>> fixes that.
>>>>
>>>
>>> The linker error is now fixed by commit r1654746. I will look at the
>>> startup crash later today if nobody else has by then.
>>
>> The startup crash that I was getting only happened on 5.21.7 or
>> higher, and is now fixed by commit r1655200.
>>
>> I don't see the loglevel problem. I'll try 5.14.2 and 2.4.6 to see if
>> I can reproduce it.
>
> I still can't reproduce this. Everything builds fine, with only the
> "expected" set of four test failures (Win32-specific, I think) using
> 5.14.2 and 2.4.6.
>
> Are you able to investigate this any more Fred?
>
>
>>
>> However, we have a problem looming on the horizon: Startup fails with
>> 5.21.8 due to this change in core perl:
>> http://perl5.git.perl.org/perl.git/commit/c910fead78 which causes an
>> access violation in modperl_env_init() when trying to replace the now
>> *const* PL_vtbls with our own versions. I fear this may be an
>> unreasonable thing for anyone to be doing in the first place? I've
>> asked on rt.perl.org:
>> https://rt.perl.org/Ticket/Display.html?id=123687
>
> We do indeed have a problem here and need to make some changes to fix
> things for 5.22 (due in May) -- see Leon's reply at
> https://rt.perl.org/Public/Bug/Display.html?id=123687#txn-1328613
>
> This shouldn't hold up our release of 2.0.9, though, which I believe
> is good for all supported stable Perls up to 5.18.4.

I've just updated mod_perl to latest trunk in Fedora and all the tests 
are passing here with httpd-2.4.10 and httpd-2.4.12 and perl-5.18.4.

Regards,
Jan Kaluza

> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
> For additional commands, e-mail: dev-help@perl.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message