perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Custerman" <...@EasySoftwareSolutions.com>
Subject RC1 test results
Date Mon, 26 Jan 2015 23:05:35 GMT
I tested RC1, but got the error "mod_perl.so: Undefined symbol
"modperl_io_perlio_restore_stdout". 

Do I miss a dependency?

 

Perl v5.18.4;   Apache 2.4.10;     FreeBSD 10.1-RELEASE

 

svn co https://svn.apache.org/repos/asf/perl/modperl/trunk/

Checked out revision 1654772.

 

[Perl Makefile.pl] => no errors

<added line to httpd.conf: "LoadModule perl_module
libexec/apache24/mod_perl.so">

 

[Make] => no errors, but lots of warnings starting with:

In file included from mod_perl.c:17:

In file included from /source/trunk/src/modules/perl/mod_perl.h:83:

In file included from /source/trunk/src/modules/perl/modperl_io.h:20:

/source/trunk/src/modules/perl/modperl_io_apache.h:37:16: warning: inline
function 'modperl_io_apache_init' is not defined [-Wundefined-inline]

MP_INLINE void modperl_io_apache_init(pTHX);

               ^

mod_perl.c:252:5: note: used here

    modperl_io_apache_init(aTHX);

    ^

In file included from mod_perl.c:17:

In file included from /source/trunk/src/modules/perl/mod_perl.h:85:

/source/trunk/src/modules/perl/modperl_filter.h:41:24: warning: inline
function 'modperl_wbucket_flush' is not defined [-Wundefined-inline]

MP_INLINE apr_status_t modperl_wbucket_flush(modperl_wbucket_t *b,

                       ^

 

[Make test]: [  error] Apache cannot spawn child processes as root,
therefore the test suite must be run as a non-privileged user.

 

<change to non-root user>

[Make test]

cd "src/modules/perl" && make

Manifying 2 pod documents

Manifying 3 pod documents

Manifying 1 pod document

Manifying 15 pod documents

"/usr/local/bin/perl5.18.4" -Iblib/arch -Iblib/lib  t/TEST -clean

APACHE_TEST_HTTPD= APACHE_TEST_APXS= APACHE_TEST_USER= APACHE_TEST_GROUP=
APACHE_TEST_PORT=  "/usr/local/bin/perl5.18.4" -Iblib/arch -Iblib/lib
t/TEST -bugreport -verbose=0

/usr/local/sbin/httpd  -d /source/trunk/t -f /source/trunk/t/conf/httpd.conf
-D APACHE2 -D PERL_USEITHREADS

using Apache/2.4.10 (prefork MPM)

 

waiting 300 seconds for server to start: .httpd: Syntax error on line 82 of
/source/trunk/t/conf/httpd.conf: Cannot load
/source/trunk/src/modules/perl/mod_perl.so into server:
/source/trunk/src/modules/perl/mod_perl.so: Undefined symbol
"modperl_io_perlio_restore_stdout"

 

<restarting apache>

Performing sanity check on apache24 configuration:

httpd: Syntax error on line 153 of /usr/local/etc/apache24/httpd.conf:
Cannot load libexec/apache24/mod_perl.so into server:
/usr/local/libexec/apache24/mod_perl.so: Undefined symbol
"modperl_io_perlio_restore_stdout"

 


Mime
View raw message