perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Kaluža <jkal...@redhat.com>
Subject Re: t/compat/conn_rec.t failure in trunk with Apache 2.4
Date Fri, 15 Aug 2014 11:10:06 GMT
On 08/14/2014 09:31 AM, Jie Gao wrote:
> These now passes "make test" on rhel6.5:
>
> t/api/conn_rec.t ........................ ok
> t/api/conn_util.t ....................... ok
>
> The only failures are the following:
>
> t/perl/ithreads3.t ...................... 1/6 # Failed test 3 in t/perl/ithreads3.t at
line 32
> # Failed test 4 in t/perl/ithreads3.t at line 33
> # Failed test 5 in t/perl/ithreads3.t at line 35
> t/perl/ithreads3.t ...................... Failed 3/6 subtests

Is that with httpd from RHEL-6.5, or is there some special configuration 
you have there? Is it with prefork MPM?

Regards,
Jan Kaluza

>
> Regards,
>
> Jie
>
> * Jan Kaluža <jkaluza@redhat.com> wrote:
>
>> Date: Thu, 14 Aug 2014 08:57:22 +0200
>> From: Jan Kaluža <jkaluza@redhat.com>
>> To: dev@perl.apache.org
>> Subject: Re: t/compat/conn_rec.t failure in trunk with Apache 2.4
>> User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101
>>   Thunderbird/24.7.0
>>
>> On 08/08/2014 08:43 AM, Jan Kaluža wrote:
>>> On 08/07/2014 01:32 PM, Niko Tyni wrote:
>>>> Hi,
>>>>
>>>> I'm trying to get the current mod_perl trunk to build on Debian unstable
>>>> (with Apache 2.4.10 and Perl 5.18.2), and I'm seeing a failure in
>>>> t/compat/conn_rec.t. It's getting an internal server error at test 3,
>>>> with this in t/logs/error_log:
>>>>
>>>>   [Thu Aug 07 14:15:39.916269 2014] [perl:error] [pid 19060:tid
>>>> 140108267251456] [client 127.0.0.1:36626] overriding
>>>> Apache2::Connection::remote_addr didn't return a CODE ref at
>>>> /home/niko/tmp/libapache2-mod-perl2/blib/lib/Apache2/compat.pm line
>>>> 252.\n
>>>>
>>>> So it's the remote_addr vs. client_addr thing again.
>>>>
>>>> The test used to work with the httpd24 branch at r1449661, and it
>>>> looks like it broke with r1497279, which restored 2.2 compatibility
>>>> in lib/Apache2/compat.pm
>>>>
>>>>   http://svn.apache.org/viewvc?view=revision&revision=1497279
>>>>
>>>> If I understand this correctly, Apache2::compat is supposed to provide
>>>> mod_perl 1.0 backward compatibility, so we want to offer remote_addr()
>>>> there even with Apache 2.4. Does the attached patch make sense? It works
>>>> for me on 2.4 and I'd expect it to work with 2.2 too (but I haven't
>>>> verified that.)
>>>
>>> Hi,
>>>
>>> yes it does. I didn't do that because of my poor Perl knowledge, so I
>>> had no idea how to detect httpd-2.4 in that particular part of code. I
>>> will commit the patch next week (right now I'm on conference and I would
>>> not like to commit the patch blindly).
>>
>> Sorry for a delay and thanks Steve for additional testing. I've
>> committed it in r1617891.
>>
>> Jan Kaluza
>>
>>> Rea
>>> Jan Kaluza
>>>
>>>>
>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
>>>> For additional commands, e-mail: dev-help@perl.apache.org
>>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
>>> For additional commands, e-mail: dev-help@perl.apache.org
>>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
>> For additional commands, e-mail: dev-help@perl.apache.org
>>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message