perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Hay <steve.m....@googlemail.com>
Subject Re: httpd24 on Windows?
Date Wed, 30 Oct 2013 18:24:12 GMT
On 30 October 2013 11:07, Jan Kaluža <jkaluza@redhat.com> wrote:
> On 10/29/2013 12:52 PM, Jan Kaluža wrote:
>>
>> On 10/28/2013 10:05 AM, Steve Hay wrote:
>>>
>>> On 4 October 2013 18:04, Steve Hay <steve.m.hay@googlemail.com> wrote:
>>>>
>>>> On 18 September 2013 12:31, Jan Kaluža <jkaluza@redhat.com> wrote:
>>>>>
>>>>> On 09/18/2013 12:46 PM, Steve Hay wrote:
>>>>>>
>>>>>>
>>>>>> On 18 September 2013 11:32, Jan Kaluža <jkaluza@redhat.com>
wrote:
>>>>>>>
>>>>>>>
>>>>>>> Hi,
>>>>>>>
>>>>>>> what's the state of mod_perl httpd24 branch on Windows currently?
I
>>>>>>> somehow
>>>>>>> got lost in the updates and I'm not sure what's the current state.
>>>>>>>
>>>>>>> Does it compile and work properly if you build against httpd-2.2?
>>>>>>> If it
>>>>>>> does, maybe we could do the merge and think about release even
>>>>>>> when it
>>>>>>> does
>>>>>>> not work currently on Windows with httpd-2.4.
>>>>>>>
>>>>>>> Lot of people are probably interested in mod_perl for Linux and
not
>>>>>>> releasing working code just because of Windows build seems to
be
>>>>>>> bad idea
>>>>>>> to
>>>>>>> me. Maybe we could get more people to try fixing mod_perl on
Windows
>>>>>>> using
>>>>>>> this strategy too.
>>>>>>>
>>>>>>
>>>>>> This sounds like a good plan, but can I get back to you on this in
a
>>>>>> few days time? I'm currently waylaid with the release of perl-5.19.4
>>>>>> and I've forgotten myself where I got to with this on Windows!
>>>>>>
>>>>>
>>>>> Great :). I've just wanted to resurrect this discussion after a while.
>>>>>
>>>>
>>>> I've tried the current httpd24 branch with Apache Lounge's 2.4.6 and
>>>> my own build of Perl 5.19.4. The build works fine but the test suite
>>>> crashes httpd.exe in t/api/add_config.t ("free from wrong pool"),
>>>> which I'm sure was not happening for me previously.
>>>
>>>
>>> I've been looking more at this but haven't figured it out yet.
>>>
>>> Debugging the test server processing the URL
>>> http://localhost:8562/TestAPI__add_config/, I find that it crashes in
>>> modperl_cleanup_pnotes() - in Safefree() on the first call to
>>> Perl_hv_undef_flags():
>>>
>>>          if (header->interpreter != aTHX) {
>>>          Perl_croak_nocontext("panic: free from wrong pool, %p!=%p",
>>>                       header->interpreter, aTHX);
>>>          }
>>>
>>> The header->interpreter is the value saved away in cleanup_data->perl
>>> by modperl_pnotes_cleanup_data(), which is registered as the cleanup
>>> routine when the pnotes is made in modperl_pnotes(), so that's been
>>> correctly restored to aTHX in modperl_cleanup_pnotes(), but the aTHX
>>> in Safefree() is different and I don't know why, or how this was
>>> working before :-/
>>>
>>
>> Hm, I have no idea what's going on here, but it does not happen for me
>> with older Perl. The good thing is that Fedora 20 just updated to
>> Perl-5.18, so I will try to install F20 and Perl-5.18 and give it a try.
>> Will write you soon how it worked.
>
>
> The tests works on Linux even with Perl-5.18, so I presume it's caused by
> the Perl build options on Windows or it's Windows-only related bug...
>

I've now tried other perls (5.16.0, 5.18.0 and 5.19.4) in other build
configurations (with/without PERL_IMPLICIT_SYS) and can confirm that
the crash only occurs with perls built with PERL_IMPLICIT_SYS enabled.
I generally use perl with that disabled (although that isn't the
default configuration), so that's probably what I was doing when I had
this working back in July.

That is indeed a Windows-specific thing, unfortunately :-/

I will see what I can do to fix it since most users will indeed have
the default configuration (certainly ActivePerl and Strawberry Perl
both do) and hence experience the crash.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message