perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fairlight <fairl...@iglou.com>
Subject mod_perl2 on CentOS 6 compile issue
Date Wed, 03 Apr 2013 17:03:37 GMT
I'm trying to compile mod_perl2 (v2.0.7 and have also tried the SVN tree)
on CentOS 6 64-bit against Perl 5.16.3 and Apache 2.2.24 (latest stable APR
and APR-util packages, as well).  I keep hitting this error:

cc -shared -O2 -L/usr/local/lib -fstack-protector \
         \
        mod_perl.lo modperl_interp.lo modperl_tipool.lo modperl_log.lo
modperl_config.lo modperl_cmd.lo modperl_options.lo modperl_callback.lo
modperl_handler.lo modperl_gtop.lo modperl_util.lo modperl_io.lo
modperl_io_apache.lo modperl_filter.lo modperl_bucket.lo modperl_mgv.lo
modperl_pcw.lo modperl_global.lo modperl_env.lo modperl_cgi.lo
modperl_perl.lo modperl_perl_global.lo modperl_perl_pp.lo modperl_sys.lo
modperl_module.lo modperl_svptr_table.lo modperl_const.lo
modperl_constants.lo modperl_apache_compat.lo modperl_error.lo
modperl_debug.lo modperl_common_util.lo modperl_common_log.lo
modperl_hooks.lo modperl_directives.lo modperl_flags.lo modperl_xsinit.lo
modperl_exports.lo  -Wl,-E  -fstack-protector -L/usr/local/lib
-L/usr/local/lib/perl5/5.16.3/x86_64-linux/CORE -lperl -lnsl -ldl -lm
-lcrypt -lutil -lc \
        -o mod_perl.so
/usr/bin/ld: /usr/local/lib/perl5/5.16.3/x86_64-linux/CORE/libperl.a(op.o):
relocation R_X86_64_32S against `PL_sv_yes' can not be used when making a
shared object; recompile with -fPIC
/usr/local/lib/perl5/5.16.3/x86_64-linux/CORE/libperl.a: could not read
symbols: Bad value
collect2: ld returned 1 exit status
make[1]: *** [mod_perl.so] Error 1
make[1]: Leaving directory `/root/mod_perl-2.0.7/src/modules/perl'
make: *** [modperl_lib] Error 2

I've revised the Makefile in the appropriate directory to do the final link
with -fPIC, and it -still- comes up with the same error.

I'm migrating from a CentOS 5 box, and have never had troubles compiling
mod_perl before.

The libperl.a -will- respond to an `nm -s`, so I'm not sure exactly what
the problem is.  

Both the official stable version and the SVN tree react identically.

Could I please get some assistance in getting this compile working.  It's
just about the last step in my [forced, time-constrained] VPS migration.

Thanks!

mark->

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message