perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Prime <adam.pr...@utoronto.ca>
Subject Re: Minimum version of perl supported?
Date Mon, 18 Mar 2013 19:45:20 GMT
Sounds good to me

On 13-03-18 02:05 PM, Steve Hay wrote:
> The core's version of old already excludes 5.12. According to
> perlpolicy.pod, only the two most recent stable release series are
> supported: currently 5.14 and 5.16, and with the imminent release of
> 5.18 that means 5.14 will drop off support too.
>
> Do we want to be that drastic? It's quite a change from the current
> README, but I don't see why not. I always have the impression that
> people are keen to use the latest stable Apache, so why shouldn't we
> expect them to use recent perls too? We aren't saying that it doesn't
> work with perls older than 5.14, just that we don't undertake to solve
> problems with such perls (although we still might if, as you say, it
> happens to be a two-line change to do so).
>
> So I would be in favour of changing the README to say that we only
> undertake to support currently supported perl versions (we don't even
> need to enumerate them, just leave the statement at that), and maybe add
> a note to the effect that things are currently known to work back to
> 5.8.2 (and possibly earlier in some configurations) but that this is not
> officially supported.
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message