perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe_schae...@yahoo.com>
Subject Re: Minimum version of perl supported?
Date Mon, 18 Mar 2013 18:07:07 GMT
+1.




>________________________________
> From: Steve Hay <Steve.Hay@verosoftware.com>
>To: Adam Prime <adam.prime@utoronto.ca>; dev@perl.apache.org 
>Sent: Monday, March 18, 2013 2:05 PM
>Subject: RE: Minimum version of perl supported?
> 
>The core's version of old already excludes 5.12. According to
>perlpolicy.pod, only the two most recent stable release series are
>supported: currently 5.14 and 5.16, and with the imminent release of
>5.18 that means 5.14 will drop off support too.
>
>Do we want to be that drastic? It's quite a change from the current
>README, but I don't see why not. I always have the impression that
>people are keen to use the latest stable Apache, so why shouldn't we
>expect them to use recent perls too? We aren't saying that it doesn't
>work with perls older than 5.14, just that we don't undertake to solve
>problems with such perls (although we still might if, as you say, it
>happens to be a two-line change to do so).
>
>So I would be in favour of changing the README to say that we only
>undertake to support currently supported perl versions (we don't even
>need to enumerate them, just leave the statement at that), and maybe add
>a note to the effect that things are currently known to work back to
>5.8.2 (and possibly earlier in some configurations) but that this is not
>officially supported.
>
>
>> -----Original Message-----
>> From: Adam Prime [mailto:adam.prime@utoronto.ca]
>> Sent: 18 March 2013 12:39
>> To: dev@perl.apache.org
>> Subject: Re: Minimum version of perl supported?
>> 
>> I can't find the thread, but i think when we last ran into a
>> compatibility problem with 5.8 and newer perls we decided that we
>> weren't going to support anything "old" unless it was easy.  In that
>> case it was a two line change to support 5.8, so we did.
>> 
>> I'm not sure how we want to define "old" right now though.  I'd guess
>> we might want to stick to whatever core's version of old is (which i
>> think might mean that 5.12 is on the edge of becoming 'old'.
>> 
>> The README clearly needs to get updated.
>> 
>> Adam
>> 
>> On 03/18/2013 05:23 AM, Steve Hay wrote:
>> > The README file currently lists three different minimum perl
>versions
>> > supported by mod_perl, depending on how mod_perl is to be built:
>> >
>> > * 5.6.1 for dynamic mod_perl with prefork mpm, or static mod_perl
>> with
>> > prefork mpm and ithreads support
>> > * 5.8.0 for dynamic or static mod_perl with non-prefork mpm and
>> > ithreads support
>> > * 5.8.2 for static mod_perl with prefork mpm and without ithreads
>> > support
>> >
>> > I only build mod_perl on Windows and never build it static, but
>using
>> > a default perl configuration (which is with ithreads on Windows) I
>> > find that mod_perl (from svn) currently doesn't build with 5.8.0:
>> >
>> > mod_perl.lo : error LNK2019: unresolved external symbol
>> > __imp__PL_op_mutex referenced in function _modperl_sys_term
>> > mod_perl.lo : error LNK2019: unresolved external symbol
>> > __imp__PL_thr_key referenced in function _modperl_sys_term
>> mod_perl.lo
>> > : error LNK2019: unresolved external symbol __imp__PL_curinterp
>> > referenced in function _modperl_sys_term
>> >
>> > It builds and tests ok (bar one or two test failures) with 5.8.1 and
>> > 5.8.2, though.
>> >
>> > I haven't looked much into trying to fix it, but should I bother at
>> all?
>> > Is it wiser to simply increase the minimum version of perl
>supported?
>> > Some folks are doubtless still using 5.8.x, but I doubt that there
>is
>> > any demand for 5.8.0. And is anyone seriously still using 5.6.x?
>Even
>> > if they are, do we need to say that we "support" it?!
>> >
>> > Perhaps it would be sensible to increase the minimum supported
>> version
>> > to 5.8.2 for whatever flavour is being built?
>> >
>> >
>---------------------------------------------------------------------
>> > To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org For
>> additional
>> > commands, e-mail: dev-help@perl.apache.org
>> >
>> 
>> 
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org For additional
>> commands, e-mail: dev-help@perl.apache.org
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
>For additional commands, e-mail: dev-help@perl.apache.org
>
>
>
>
Mime
View raw message