perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Kaluža <jkal...@redhat.com>
Subject Re: httpd24 branch
Date Wed, 27 Feb 2013 06:47:32 GMT
On 02/26/2013 03:52 AM, Andy Colson wrote:
> On 02/25/2013 05:20 AM, Jan Kaluža wrote:
>> On 02/22/2013 09:02 PM, Andy Colson wrote:
>>> After applying mod_perl-2.0.5-nolfs.patch, then re-making, I got this on
>>> make test:
>>>
>>> t/TEST -clean
>>> [warning] setting ulimit to allow core files
>>> ulimit -c unlimited; /usr/bin/perl5.16.2
>>> /home/andy/apps/mod_perl24/t/TEST -clean
>>> APACHE_TEST_GROUP= APACHE_TEST_HTTPD= APACHE_TEST_PORT=
>>> APACHE_TEST_USER= APACHE_TEST_APXS= \
>>> /usr/bin/perl5.16.2 -Iblib/arch -Iblib/lib \
>>> t/TEST -bugreport -verbose=0
>>> [warning] setting ulimit to allow core files
>>> ulimit -c unlimited; /usr/bin/perl5.16.2
>>> /home/andy/apps/mod_perl24/t/TEST -bugreport -verbose=0
>>> /usr/sbin/httpd  -d /home/andy/apps/mod_perl24/t -f
>>> /home/andy/apps/mod_perl24/t/conf/httpd.conf -D APACHE2 -D
>>> PERL_USEITHREADS
>>> using Apache/2.4.3 (event MPM)
>>>
>>> waiting 300 seconds for server to start: .[Fri Feb 22 13:55:18.809928
>>> 2013] [env:warn] [pid 7261:tid 3070203648] AH01506: PassEnv variable
>>> LD_LIBRARY_PATH was undefined
>>> AH00526: Syntax error on line 296 of
>>> /home/andy/apps/mod_perl24/t/conf/httpd.conf:
>>> Unknown Authz provider: valid-user
>>> [  error]
>>> server has died with status 255 (t/logs/error_log wasn't created, start
>>> the server in the debug mode)
>>> sh: line 1:  7165 Terminated              /usr/bin/perl5.16.2
>>> /home/andy/apps/mod_perl24/t/TEST -bugreport -verbose=0
>>> make: *** [run_tests] Error 143
>>>
>>>
>>> I've played with my systems /etc/httpd/httpd.conf file, is that a
>>> problem?
>>
>> I'm not sure how exactly Apache-Test works, but there are some
>> comments about "system-wide httpd.conf", so I presume it gets the list
>> of modules from the system-wide httpd.conf.
>>
>> Please check you have "LoadModule authz_user_module
>> modules/mod_authz_user.so" included in your system-wide httpd.conf and
>> check if it's included in /home/andy/apps/mod_perl24/t/conf/httpd.conf.
>>
>> "valid-user" should be provided by that httpd module.
>>
>>> -Andy
>
> Yep, that works.  I had to enable these (in my system httpd.conf) to get
> everything to run thru:
>
> authz_user_module
> authn_core_module
> access_compat_module
>
>
> Hum... I got to this test and it just froze:
>
> t/protocol/echo_filter.t ................ 1/3

You could try running just this single test using: "t/TEST 
t/protocol/echo_filter.t" and check the httpd log in t/logs

>
> I'll play around and see if I can figure out why.
>
> -Andy
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
> For additional commands, e-mail: dev-help@perl.apache.org
>

Jan Kaluza


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message