perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Colson <a...@squeakycode.net>
Subject Re: httpd24 branch
Date Fri, 22 Feb 2013 20:02:06 GMT
On 2/21/2013 1:41 AM, Jan Kaluža wrote:
> Hi,
>
> I think I've committed all my patches [1] to httpd24 branch. It builds
> OK for me and I think it's now time for more people to build it and
> report your problems with this branch.
>
> To compile it, I just checkout the httpd24 and run:
>
> /usr/bin/perl Makefile.PL MP_APXS=/usr/bin/apxs
> MP_APR_CONFIG=/usr/bin/apr-1-config
>
> make
>
> If you want to run tests, you have to at first create ./t/run directory
> (to create this automatically, I would have to patch Apache-Test which I
> can't since it's separate component and lives outside my httpd24 branch
> if I'm right)
>
> Then you can just run 'make test'.
>
> The only failing test is t/directive/perlloadmodule3.t. I don't know
> perl enough to parse that code which merges configurations in this test
> yet.
>



Make worked fine for me.  Make test died again because of the lfs thing:

On 9/26/2012 3:23 AM, Jan Kaluža wrote:
 >>
 >> Oh, I've checked the patches we use in Fedora and I think this problem
 >> is fixed by this patch:
 >>
 >> http://jkaluza.fedorapeople.org/mod_perl/mod_perl-2.0.5-nolfs.patch
 >>
 >> It's unrelated to httpd24, but I think this patch could fix it for you.
 >> At least I think I remember this backtrace.
 >
 > Found downstream bugreport for this one:
 > https://bugzilla.redhat.com/show_bug.cgi?id=730832
 >

After applying mod_perl-2.0.5-nolfs.patch, then re-making, I got this on 
make test:

t/TEST -clean
[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/bin/perl5.16.2 
/home/andy/apps/mod_perl24/t/TEST -clean
APACHE_TEST_GROUP= APACHE_TEST_HTTPD= APACHE_TEST_PORT= 
APACHE_TEST_USER= APACHE_TEST_APXS= \
/usr/bin/perl5.16.2 -Iblib/arch -Iblib/lib \
t/TEST -bugreport -verbose=0
[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/bin/perl5.16.2 
/home/andy/apps/mod_perl24/t/TEST -bugreport -verbose=0
/usr/sbin/httpd  -d /home/andy/apps/mod_perl24/t -f 
/home/andy/apps/mod_perl24/t/conf/httpd.conf -D APACHE2 -D PERL_USEITHREADS
using Apache/2.4.3 (event MPM)

waiting 300 seconds for server to start: .[Fri Feb 22 13:55:18.809928 
2013] [env:warn] [pid 7261:tid 3070203648] AH01506: PassEnv variable 
LD_LIBRARY_PATH was undefined
AH00526: Syntax error on line 296 of 
/home/andy/apps/mod_perl24/t/conf/httpd.conf:
Unknown Authz provider: valid-user
[  error]
server has died with status 255 (t/logs/error_log wasn't created, start 
the server in the debug mode)
sh: line 1:  7165 Terminated              /usr/bin/perl5.16.2 
/home/andy/apps/mod_perl24/t/TEST -bugreport -verbose=0
make: *** [run_tests] Error 143


I've played with my systems /etc/httpd/httpd.conf file, is that a problem?

-Andy





---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message