perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Colson <a...@squeakycode.net>
Subject Re: trying mod_perl patches for httpd 2.4
Date Mon, 24 Sep 2012 13:55:42 GMT
On 9/24/2012 1:02 AM, Jan Kalu┼ża wrote:
> On 09/22/2012 06:58 PM, Andy Colson wrote:
>> Bummer...
>>
>> make test  totally dies:
>>

>> /usr/sbin/httpd  -d /home/andy/apps/mod_perl-2.0/t -f
>> /home/andy/apps/mod_perl-2.0/t/conf/httpd.conf -D APACHE2 -D
>> PERL_USEITHREADS
>> using Apache/2.4.3 (event MPM)
>>
>> waiting 300 seconds for server to start: .[Sat Sep 22 11:56:13.629096
>> 2012] [env:warn] [pid 2330:tid 3069482752] AH01506: PassEnv variable
>> LD_LIBRARY_PATH was undefined
>
> ^ This looks like the problem, but I'm not sure why it's not set for
> you. I will try to reproduce it during this week, but it works properly
> for me on Fedora.
>


 From what little googling I did, and some prior emails to the group, 
I'm wondering if its mpm/threaded related?

Is Fedora using event mpm with a threaded perl?  (also, on perl 5.16.1?)

I think I kinda figured out the MP_TRACE stuff, would that be helpful at 
all?

Also my gdb foo is not strong, but I'd be happy to attempt anything if 
you think it might be useful.

Ahh, hang on... what if I dont have LD_LIBRARY_PATH set to anything? 
I'm almost positive it isnt set at all, anywhere.  Slackware uses 
/etc/ld.so.conf and not LD_LIBRARY_PATH.  (this might be babble talk, 
I'm outta my league here)

Thanks for your time on this,

-Andy


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message