perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Kalu┼ża <jkal...@redhat.com>
Subject Re: trying mod_perl patches for httpd 2.4
Date Mon, 24 Sep 2012 06:02:51 GMT
On 09/22/2012 06:58 PM, Andy Colson wrote:
> Bummer...
>
> make test  totally dies:
>
>
>
> ulimit -c unlimited; /usr/bin/perl5.16.1
> /home/andy/apps/mod_perl-2.0/t/TEST -bugreport -verbose=0
> AH00558: httpd: Could not reliably determine the server's fully
> qualified domain name, using 192.168.1.3. Set the 'ServerName' directive
> globally to suppress this message
> Not a CODE reference at /usr/lib/perl5/DynaLoader.pm line 213.
> END failed--call queue aborted at
> /home/andy/apps/mod_perl-2.0/blib/lib/ModPerl/Const.pm line 213.
> Compilation failed in require at
> /home/andy/apps/mod_perl-2.0/blib/lib/Apache2/Const.pm line 18.
> BEGIN failed--compilation aborted at
> /home/andy/apps/mod_perl-2.0/blib/lib/Apache2/Const.pm line 18.
> Compilation failed in require at
> /home/andy/apps/mod_perl-2.0/t/response/TestApache/subprocess.pm line 13.
> BEGIN failed--compilation aborted at
> /home/andy/apps/mod_perl-2.0/t/response/TestApache/subprocess.pm line 13.
> Compilation failed in require at
> /home/andy/apps/mod_perl-2.0/Apache-Test/lib/Apache/TestConfigPerl.pm
> line 648.
> Attempt to reload Apache2/Const.pm aborted.
> Compilation failed in require at
> /home/andy/apps/mod_perl-2.0/t/response/TestDirective/perlmodule.pm line
> 16.
> BEGIN failed--compilation aborted at
> /home/andy/apps/mod_perl-2.0/t/response/TestDirective/perlmodule.pm line
> 16.
> Compilation failed in require at
> /home/andy/apps/mod_perl-2.0/Apache-Test/lib/Apache/TestConfigPerl.pm
> line 648.
> Attempt to reload Apache2/Const.pm aborted.
> Compilation failed in require at
> /home/andy/apps/mod_perl-2.0/t/response/TestDirective/perlrequire.pm
> line 18.
> BEGIN failed--compilation aborted at
> /home/andy/apps/mod_perl-2.0/t/response/TestDirective/perlrequire.pm
> line 18.
> Compilation failed in require at
> /home/andy/apps/mod_perl-2.0/Apache-Test/lib/Apache/TestConfigPerl.pm
> line 648.
> /usr/sbin/httpd  -d /home/andy/apps/mod_perl-2.0/t -f
> /home/andy/apps/mod_perl-2.0/t/conf/httpd.conf -D APACHE2 -D
> PERL_USEITHREADS
> using Apache/2.4.3 (event MPM)
>
> waiting 300 seconds for server to start: .[Sat Sep 22 11:56:13.629096
> 2012] [env:warn] [pid 2330:tid 3069482752] AH01506: PassEnv variable
> LD_LIBRARY_PATH was undefined

^ This looks like the problem, but I'm not sure why it's not set for 
you. I will try to reproduce it during this week, but it works properly 
for me on Fedora.

> [  error] oh crap, server dumped core
> [  error] for stacktrace, run: gdb /usr/sbin/httpd -core
> /home/andy/apps/mod_perl-2.0/core
> [  error]
> server has died with status 255 (t/logs/error_log wasn't created, start
> the server in the debug mode)
> [  error] oh dangit, server dumped core
> [  error] for stacktrace, run: gdb /usr/sbin/httpd -core
> /home/andy/apps/mod_perl-2.0/core
> sh: line 1:  2234 Terminated              /usr/bin/perl5.16.1
> /home/andy/apps/mod_perl-2.0/t/TEST -bugreport -verbose=0
> make: *** [run_tests] Error 143
>
>
> What do I do now?
 >
> -Andy
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
> For additional commands, e-mail: dev-help@perl.apache.org
>

Regards,
Jan Kaluza


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message