perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Colson <a...@squeakycode.net>
Subject Re: trying mod_perl patches for httpd 2.4
Date Sat, 22 Sep 2012 16:51:30 GMT
On 09/22/2012 11:20 AM, Andy Colson wrote:
> Hi all,
>
> I downloaded 2.0.7 source, then applied these patches:
>
> http://jkaluza.fedorapeople.org/mod_perl/all.tgz
>
>
> My first attempt:
>
> $ perl Makefile.PL
> MP_APXS unspecified, using /usr/bin/apxs
>
> no conflicting prior mod_perl version found - good.
> Configuring Apache/2.4.3 mod_perl/2.0.7 Perl/v5.16.1
> [  error] Can't find apr include/ directory,
> [  error] use MP_APR_CONFIG=/path/to/apr-config
>
>
> I finally found apr-config as apr-1-config, so my second attempt worked:
>
> $ perl Makefile.PL MP_APR_CONFIG=/usr/bin/apr-1-config
> Reading Makefile.PL args from @ARGV
>     MP_APR_CONFIG = /usr/bin/apr-1-config
> MP_APXS unspecified, using /usr/bin/apxs
>
> no conflicting prior mod_perl version found - good.
> Configuring Apache/2.4.3 mod_perl/2.0.7 Perl/v5.16.1
> Checking if your kit is complete...
> Looks good
> Checking if your kit is complete...
> Looks good
> ...
> <snip>
> ...
>
>
> Then we make:
>
> $ make
> cd "src/modules/perl" && make
> make[1]: Entering directory `/home/andy/apps/mod_perl-2.0.7/src/modules/perl'
> cc -I/home/andy/apps/mod_perl-2.0.7/src/modules/perl -I/home/andy/apps/mod_perl-2.0.7/xs
-I/usr/include/apr-1 -I/usr/include/httpd -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing
-pipe -fstack-protector -I/usr/local/include -I/usr/lib/perl5/CORE -DMOD_PERL -DMP_COMPAT_1X
-D_LARGEFILE64_SOURCE -O2 -march=i486 -mtune=i686 -fPIC \
> ...
> <snip>
> ...
> cc -I/home/andy/apps/mod_perl-2.0.7/src/modules/perl -I/home/andy/apps/mod_perl-2.0.7/xs
-I/usr/include/apr-1 -I/usr/include/httpd -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing
-pipe -fstack-protector -I/usr/local/include -I/usr/lib/perl5/CORE -DMOD_PERL -DMP_COMPAT_1X
-D_LARGEFILE64_SOURCE -O2 -march=i486 -mtune=i686 -fPIC \
> -c modperl_constants.c && mv modperl_constants.o modperl_constants.lo
> modperl_constants.c: In function 'modperl_constants_lookup_apache2_const':
> modperl_constants.c:809:22: error: 'OPT_INCNOEXEC' undeclared (first use in this function)
> modperl_constants.c:809:22: note: each undeclared identifier is reported only once for
each function it appears in
> make[1]: *** [modperl_constants.lo] Error 1
> make[1]: Leaving directory `/home/andy/apps/mod_perl-2.0.7/src/modules/perl'
> make: *** [modperl_lib] Error 2
>
> I'm using:
>
> Slackware 14 (32-bit)
> Perl 5.16.1
>
>
> Any hints what I should do now?
>
> Thanks,
>
> -Andy
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
> For additional commands, e-mail: dev-help@perl.apache.org
>


Woot!  First I thought I'd better try 2.0.8 from svn.  The patches apply but I get the same
error.  Then I found:

http://www.gossamer-threads.com/lists/modperl/dev/104392#104392

So I ran:

make source_scan
make xs_generate


Then

perl Makefile.PL MP_APR_CONFIG=/usr/bin/apr-1-config

and then make built ok!

I'll continue playing...

-Andy





---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message