perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Hay" <Steve...@planit.com>
Subject RE: [RELEASE CANDIDATE]: mod_perl-2.0.6 RC1
Date Mon, 13 Feb 2012 09:15:34 GMT
I'm afraid the details are not clear to me either, but I have tried the two patches out (after
correcting an instance of code-before-declaration which VC++ doesn't accept in C files) and
I find that (with the LimitExcept change reverted as per current svn Trunk) they make no visible
difference to my setup: I don't see the "free unreferenced scalar" errors in the log file
after running the tests with or without the patches, but I do still get an "Out of memory!"
crash mid-way through the test suite either way :-(


-----Original Message-----
From: Fred Moyer [mailto:fred@redhotpenguin.com] 
Sent: 11 February 2012 17:50
To: Niko Tyni
Cc: dev@perl.apache.org; 650675@bugs.debian.org
Subject: Re: [RELEASE CANDIDATE]: mod_perl-2.0.6 RC1

On Fri, Feb 10, 2012 at 10:51 PM, Niko Tyni <ntyni@debian.org> wrote:
> Hi Fred (and hopefully the list),

Looks like it made it through.  Suggest inlining your patches next time instead of using attachments,
sometimes the list code may filter on those.
>
> as seen in <http://bugs.debian.org/650675>, we're seeing numerous 
> lines of
>  Attempt to free unreferenced scalar: SV 0x7f9c0c347490, Perl interpreter: 0x7f9c0c1a2dd0
during global destruction.
> on Debian unstable with 2.0.5 and Perl 5.14.2. I've been trying to get 
> patches through to the mod-perl dev list with no success; there seems 
> to be something broken with the list moderation. (I'd be happy to 
> provide message-ids and the like if somebody is interested, and they 
> can also be found in the bug log.)


I looked through the patches and grok the syntax, but the finer details aren't clear to me
yet.  Maybe some of the other devs
(gozer,steve,torsten) can comment on them.  I'll hold rc2 for a few days to give them a chance
to respond.


> I've verified that those still get emitted with 2.0.6 RC1. The test 
> suite passes, but
>  % grep unreferenced t/logs/error_log|wc -l
>  30

Can you post some of that error log which shows the error?


> This seems related to -Dusethreads and started with 5.13.6 or so; 
> please see
>  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650675#50
> for the full analysis including the perl change that broke this.
>
> Could you please consider these patches for 2.0.6, or let me know if 
> I've got it all wrong.

Thanks for the contribution.  Anyone else here see those errors previously, or can reproduce
them now?

>
> Thanks for your work,
> --
> Niko Tyni   ntyni@debian.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org For additional commands, e-mail: dev-help@perl.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message