perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Hay" <Steve...@planit.com>
Subject RE: 2.0.6?
Date Wed, 23 Nov 2011 17:32:17 GMT
Steve Hay wrote on 2011-11-22:
> Philippe M. Chiasson wrote on 2011-11-22:
>> On 11-11-22 03:47 , Steve Hay wrote:
>>> The SVN trunk is working fine for me on Win32 with VC++ 2010, perl
>>> 5.14.2 and apache 2.2.21.
>> 
>> Excellent! That was one of the pending items, actually.
>> 
> 
> (Actually, I should say that I do have three tests failing, but one of
> those failed in my 2.0.5 + 5.12.2 build anyway, and my current trunk +
> 5.14.2 build is working fine for me _in practice_.)
> 
[...]
> 
> I will look at the test failures that I had, but even if there isn't a
> quick fix for them then I still think it's worth rolling a release
that
> works with 5.14, and fixing the minor test failures can be the first
> thing on the plan for 2.0.7!
> 

A couple of the test failures were due to the new LWP, which I hadn't
realized were fixed already in SVN. I think I'd pulled the core C code
changes into a 2.0.5 build and tried that, so I hadn't picked up those
fixes!
 
Now that I've actually tried the current trunk for real, those problems
go away and I'm left with two failing tests: the test that has failed
for a long time anyway (apache/subprocess tests 2-5), plus a new failure
caused by rev. 1145161: moving <LimitExcept> into a <Directory />.
Unfortunately, that change to cmdparams.pm actually crashes httpd.exe
with the message "panic: free from wrong pool." in the error_log right
at the start of "nmake test" :-(

Is there some other way to workaround httpd-2.3's change to where
<LimitExcept> is allowed?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message