perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From peng wei <cnpeng...@gmail.com>
Subject Re: Fwd: svn commit: r1151596 - in /perl/modperl/branches/1.x: Changes Symbol/Symbol.xs src/modules/perl/Constants.xs src/modules/perl/Log.xs src/modules/perl/mod_perl.c src/modules/perl/mod_perl.h src/modules/perl/perl_config.c
Date Fri, 29 Jul 2011 05:17:26 GMT
Hi All,

I am sorry to sent this mail to want to get help from you.

Anyway.... I am install the perl module of DBD::Oracle on one 64 bit RedHat
Vmware,

I have installed the Oracle Instant Client, and can use sql*plus to connect
to remote Database to fetch data.

But when I use cpanp to install DBD::Oracle, it alarms below info:

**********************************************************************
   CPAN Terminal> i DBD::Oracle

[MSG] No '/root/.cpanplus/custom-sources' dir, skipping custom sources
[MSG] No '/root/.cpanplus/custom-sources' dir, skipping custom sources
[MSG] No '/root/.cpanplus/custom-sources' dir, skipping custom sources
Installing DBD::Oracle (1.28)
Running [/usr/bin/perl /usr/bin/cpanp-run-perl
/root/.cpanplus/5.8.8/build/DBD-Oracle-1.28/Makefile.PL]...
Using DBI 1.616 (for perl 5.008008 on x86_64-linux-thread-multi) installed
in /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/

Configuring DBD::Oracle for perl 5.008008 on linux
(x86_64-linux-thread-multi)

Remember to actually *READ* the README file! Especially if you have any
problems.

Installing on a linux, Ver#2.6
Using Oracle in /home/oracle
Multiple copies of Driver.xst found in:
/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/ at
/root/.cpanplus/5.8.8/build/DBD-Oracle-1.28/Makefile.PL line 37
SP2-1503: Unable to initialize Oracle call interface
SP2-0152: ORACLE may not be functioning properly

            If sqlplus failed due to a linker/symbol/relocation/library
error or similar problem
            then it's likely that you've not configured your environment
correctly.
            Specifically, your LD_LIBRARY_PATH environment variable
            set to include the directory containing the Oracle libraries.

I'm having trouble finding your Oracle version number... trying harder

WARNING: I could not determine Oracle client version so I'll just
default to version 8.0.0.0. Some features of DBD::Oracle may not work.
Oracle version based logic in Makefile.PL may produce erroneous results.
You can use "perl Makefile.PL -V X.Y.Z" to specify a your client version.

Oracle version 8.0.0.0 (8.0)
DBD::Oracle no longer supports Oracle client versions before 9.2
Try a version before 1.25 for 9 and 1.18 for 8! at
/root/.cpanplus/5.8.8/build/DBD-Oracle-1.28/Makefile.PL line 175.
BEGIN failed--compilation aborted at /usr/bin/cpanp-run-perl line 8.
[ERROR] Could not run '/usr/bin/perl Makefile.PL': Using DBI 1.616 (for perl
5.008008 on x86_64-linux-thread-multi) installed in
/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/

Configuring DBD::Oracle for perl 5.008008 on linux
(x86_64-linux-thread-multi)

Remember to actually *READ* the README file! Especially if you have any
problems.

Installing on a linux, Ver#2.6
Using Oracle in /home/oracle
Multiple copies of Driver.xst found in:
/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/ at
/root/.cpanplus/5.8.8/build/DBD-Oracle-1.28/Makefile.PL line 37
SP2-1503: Unable to initialize Oracle call interface
SP2-0152: ORACLE may not be functioning properly

            If sqlplus failed due to a linker/symbol/relocation/library
error or similar problem
            then it's likely that you've not configured your environment
correctly.
            Specifically, your LD_LIBRARY_PATH environment variable
            set to include the directory containing the Oracle libraries.

I'm having trouble finding your Oracle version number... trying harder

WARNING: I could not determine Oracle client version so I'll just
default to version 8.0.0.0. Some features of DBD::Oracle may not work.
Oracle version based logic in Makefile.PL may produce erroneous results.
You can use "perl Makefile.PL -V X.Y.Z" to specify a your client version.

Oracle version 8.0.0.0 (8.0)
DBD::Oracle no longer supports Oracle client versions before 9.2
Try a version before 1.25 for 9 and 1.18 for 8! at
/root/.cpanplus/5.8.8/build/DBD-Oracle-1.28/Makefile.PL line 175.
BEGIN failed--compilation aborted at /usr/bin/cpanp-run-perl line 8.
-- cannot continue

[ERROR] Unable to create a new distribution object for 'DBD::Oracle' --
cannot continue

*** Install log written to:
  /root/.cpanplus/install-logs/DBD-Oracle-1.28-1311839802.log

Error installing 'DBD::Oracle'
Problem installing one or more modules
*** You can view the complete error buffer by pressing 'p' ***

CPAN Terminal>

**********************************************************************

2011/7/28 Salvador Ortiz Garcia <sog@msg.com.mx>

>
> The commited patch has two typos:
>
>
> On 07/27/2011 02:15 PM, phred@apache.org wrote:
>
>> --- perl/modperl/branches/1.x/src/**modules/perl/mod_perl.h (original)
>> +++ perl/modperl/branches/1.x/src/**modules/perl/mod_perl.h Wed Jul 27
>> 19:15:01 2011
>> @@ -1026,6 +1026,14 @@ else { \
>>  #define PERL_HEADER_PARSER_CREATE(s)
>>  #endif
>>
>> +#ifndef GvCV_set
>> +#define GvCV_set(gv, cv) (GvCV(gv) = (cv))
>> +#endif
>> +
>> +#ifndef GvCV_set
>>
> s/GvCV/CvGV/
>
>  +#define CvGV_set(gv, cv) (CvVG(gv) = (cv))
>>
> s/VG/GV/
>
>  +#endif
>> +
>>  typedef struct {
>>     array_header *PerlPassEnv;
>>     array_header *PerlRequire;
>>
>
> Btw, Wade's patch, posted on Jul 11, is very similar to mine, posted on Jun
> 28.
>
> Regards.
>
> Salvador Ortiz.
>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.**org<dev-unsubscribe@perl.apache.org>
> For additional commands, e-mail: dev-help@perl.apache.org
>
>

Mime
View raw message