perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Hay" <Steve...@planit.com>
Subject RE: Anything left before 2.0.6?
Date Fri, 08 Jul 2011 17:20:33 GMT
Steve Hay wrote on 2011-07-08:
> Torsten Förtsch wrote on 2011-06-28:
>> On Tuesday, June 28, 2011 00:26:56 Fred Moyer wrote:
>>> I am planning to roll some release candidates next week.  I think
>>> we've tested against 5.14, and there was the LWP 6.x issue that
>>> doesn't seem to be a blocker.  Anything else?
>>> Would be nice if I had the httpd 2.4 port ready. But I wouldn't see
>> that as a blocker at all.
>> 
>> A few weeks ago I called for testing with 5.14. There was no reply.
>> Optimistically we can take this as "no problems encountered",
>> pessimistically as "no one bothered to test". But perhaps a release
>> candidate will get more attention (hopefully). Anyway, I think it's
>> time.
>> 
> 
> I've belatedly got round to testing modperl/trunk with perl-5.14.1 (and
> httpd-2.2.17) on Windows XP (using VS2010).
> 
> It builds fine except for a minor wobble from Makefile.PL saying
> 
> Use of uninitialized value in concatenation (.) or string at
> lib/Apache2/Build.pm line 1725.
> Use of uninitialized value in concatenation (.) or string at
> lib/Apache2/Build.pm line 1725.
> Checking if your kit is complete...
> Looks good
> Note (probably harmless): No library found for /src/modules/perl/.lib
> 
> for each of Apache2::Reload and Apache2::SizeLimit. I've not seen that
> happen before but it didn't stop it from building normally otherwise.
> 

Seems like it happened with 2.0.5 as well, actually, when doing a fresh build of everything.
It doesn't happen with 2.0.4, though, so it must be addition of Apache-Reload and Apache-SizeLimit
into the mod_perl distribution as of 2.0.5 that caused it.

I think I didn't see this when testing 2.0.5 before because if I install into a perl tree
which already has a previous mod_perl (+ Apache::Reload + Apache::SizeLimit?) in it then the
problem doesn't occur, so I probably just tested 2.0.5 against a perl tree which already had
2.0.4 in it.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message