perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@redhotpenguin.com>
Subject Re: Apache::Test & LWP 6.x - don't
Date Fri, 20 May 2011 18:19:56 GMT
That sounds like a bug in LWP.  Have you contacted the maintainer?

2011/5/20 Torsten Förtsch <torsten.foertsch@gmx.net>:
> Hi,
>
> if someone needs a nice little project that requires only Perl skills
> convert A::T to the new LWP 6.x and/or fix the bugs in LWP 6.
>
> Currently, the combination of A::T and LWP 6 is not really usable.
> Modperl tests work mostly, though, sometimes they simply hang. For
> example I had a test (modperl, httpd-framework or libapreq (don't
> recall)) where the test reads 20000 bytes from the client. Sometimes the
> test simply hangs but not always. I traced the conversation with tcpdump
> and noticed the client sends the request header, the server the response
> header, then the server waits for the body and LWP waits for god knows
> what.
>
> I got back to LWP 5. Now all the tests work again.
>
> Torsten Förtsch
>
> --
> Need professional modperl support? Hire me! (http://foertsch.name)
>
> Like fantasy? http://kabatinte.net
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
> For additional commands, e-mail: dev-help@perl.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message