perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Hay" <Steve...@planit.com>
Subject RE: modperl - quo vadis?
Date Mon, 31 Jan 2011 08:29:51 GMT
Torsten Förtsch wrote on 2011-01-28:
> Do we have any developer who builds/tests/cares about modperl on
> windows? If yes, I withdraw the question. If not, how can we claim
> modperl runs on windows? I have tried to build apache & modperl on
> windows. But my last encounter with it as a developer dates back to the
> mid-nineties. So I failed badly already on the preliminaries. That
> doesn't mean anything if we have someone on the team who can.
> 
> BTW, could this someone please document in a fool-proof way (for me)
> how to
> build modperl on windows starting with which compilers to use? Where do
> I get
> or how do I build an usable openssl, that sort of stuff. Suppose you
> have a
> freshly installed Vista or Win7 virtual machine.
> 

Yes, I build on Windows and care about Windows support. It all works pretty-much out-of-the-box
for me, certainly on XP using VS2008 (VC9) (either the full commercial version, or the free
Express version):

Build Perl:
nmake INST_TOP=C:\perl5 CCTYPE=MSVC90 USE_IMP_SYS=undef PERL_MALLOC=define
nmake INST_TOP=C:\perl5 CCTYPE=MSVC90 USE_IMP_SYS=undef PERL_MALLOC=define test
nmake INST_TOP=C:\perl5 CCTYPE=MSVC90 USE_IMP_SYS=undef PERL_MALLOC=define install

Build Apache:
nmake /f Makefile.win INSTDIR=C:\apache2.2 installr

Install apxs:
perl Configure.pl --with-apache2=C:/apache2.2 --with-apache-prog=httpd.exe

Build mod_perl2:
perl Makefile.PL MP_AP_PREFIX=C:/apache2.2
nmake
nmake test
nmake install

Build libapreq2:
[Make sure C:\apache2.2\conf\httpd.conf loads mod_perl]
perl Makefile.PL
nmake
nmake test
nmake install

There are a few test failures that I get but haven't had a chance to look into yet (apache/subprocess
tests 2-5, hooks/authen_basic test 4, hooks/authz test 4 and modules/apache_status tests 14-15).

I don't personally use OpenSSL in my mod_perl setup, but do use it for other purposes. It
also builds fine on Windows:
perl Configure VC-WIN32 --prefix=/openssl --openssldir=/openssl
ms\do_ms
nmake /f ms\nt.mak
cd out32
..\ms\test
cd ..
nmake /f ms\nt.mak install

Perl support for VS2010 (VC10) is now in bleadperl (including 5.13.9), but not *quite* complete
yet. VS2005 (VC8), VS2003 (VC7) and VC6 used to work too and probably still do (but some of
the earlier free Express versions have various dependencies on SDKs etc: the VS2008 or VS2010
versions are better because they are self-contained).

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message