perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Förtsch <torsten.foert...@gmx.net>
Subject Re: RT 32992
Date Fri, 16 Apr 2010 16:13:41 GMT
On Friday 16 April 2010 04:02:17 Fred Moyer wrote:
> https://rt.cpan.org/Ticket/Display.html?id=32992
> 
> Taking a poll again of who supports this issue resolution.  Given that
> the previous stable version of perl (5.10.1) has version.pm bundled
> (current version is 5.12.0), I think this is safe move.  5.8.8 does
> not have version.pm bundled, but it is easy enough to install.
> 
Sorry, but I don't understand the source of the problem. Is it that EU::MM 
uses version numbers of the form 6.06_12? We need at least 6.06, right? 
6.06_01 will do as well, right?

$ perl -Mversion -le 'my $v1="6.05_99"; my $v2="6.06"; print "less" if 
0+$v1<0+$v2'
less
$ perl -Mversion -le 'my $v1="6.05_99"; my $v2="6.06"; print "less" if 
version->new($v1)<version->new($v2)'
less

$ perl -Mversion -le 'my $v1="6.06"; my $v2="6.06_01"; print "less" if 
0+$v1<0+$v2'
$ perl -Mversion -le 'my $v1="6.06"; my $v2="6.06_01"; print "less" if 
version->new($v1)<version->new($v2)'
less

There is a difference. Without version it is

  6.05_99<6.06 and 6.06==6.06_01

though with version it is

  6.05_99<6.06 and 6.06<6.06_01

But our case is 6.05_99<6.06. Obviously I have missed something.

Torsten Förtsch

-- 
Need professional modperl support? Hire me! (http://foertsch.name)

Like fantasy? http://kabatinte.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message