perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David E. Wheeler" <da...@kineticode.com>
Subject Re: Test::Apache Failure with Apache 2.2
Date Sun, 04 May 2008 02:13:43 GMT
On May 3, 2008, at 17:52, Fred Moyer wrote:

>> Not sure why there's a difference here between mod_perl 1 and  
>> mod_perl 2, but I'm happy that the solution seems to be simple. Is  
>> this something that's documented somewhere?
>
> MODPERL2 is documented here, although it doesn't answer the question  
> of why the server starts with that directive and doesn't start  
> without it:

Yes, I knew that MODPERL2 was documented, I just don't know why it's  
necessary here. Sorry I wasn't clearer.

> Most instances of the server not starting which have not been  
> related to the timeout being too low were missing test skips if a  
> certain module wasn't present (i.e. mod_alias, etc).  I know I've  
> fixed a few of those issues, but there may be some remaining.  My  
> guess is that your httpd builds may  not have the exact same modules  
> compiled in or loaded dynamically.

I'm not sure how the Perl block makes a difference.

> I don't really understand why you need that perl section at all  
> though, Apache::Test should be picking up those library paths  
> implicitly.

When I removed it, tests failed under mod_perl 1. Odd.

Thanks,

David

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message