perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philippe M. Chiasson" <go...@apache.org>
Subject Re: [RELEASE CANDIDATE] mod_perl-1.31 RC4
Date Thu, 17 Apr 2008 08:33:51 GMT
David E. Wheeler wrote:
> On Apr 2, 2008, at 10:21, David E. Wheeler wrote:
> 
>> benedict# make
>> (cd ./apaci && PERL5LIB=/usr/local/src/mod_perl-1.31-rc4/lib: make)
>> make[1]: *** No rule to make target `libperl.so', needed by `lib'.   
>> Stop.
>> make: *** [apxs_libperl] Error 2
>>
>> This is on Mac OS X 10.5.2 with Perl 5.10 compiled like so:
>>
>> sh Configure -des -Duseshrplib -Dperladmin=david@kineticode.com -Dcf_email=david@kineticode.com
>> make
>> make test
>> make install
>>
>> *sigh*. I hope this is something simple.

Yes, apache on OSX picks '.so' as the dynamic library extensions.
Perl, on the other hand, picks '.bundle'

> Anyone have any ideas on this? I'm attempting to compile mod_perl as a  
> DSO outside of the Apache source tree using APXS. There must just be a  
> typo or something somewhere, yes? I mean, this worked for me beforeā€¦

So you end up with a Makefile that goes like

all: libperl.so (thank you Apache)

libperl.bundle: (thank you Perl/OSX)

Try with:

$> make PERL_DLEXT=so

-- 
Philippe M. Chiasson     GPG: F9BFE0C2480E7680 1AE53631CB32A107 88C3A5A5
http://gozer.ectoplasm.org/       m/gozer\@(apache|cpan|ectoplasm)\.org/


Mime
View raw message