perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Foertsch <torsten.foert...@gmx.net>
Subject [PATCH] Problem with Apache2::XSLoader
Date Wed, 19 Mar 2008 15:04:02 GMT
Hi,

I have an XS module that is loaded with:

use Apache2::XSLoader ();
our $VERSION = '0.05';
Apache2::XSLoader::load __PACKAGE__;

Is Apache2::XSLoader for public use or is it only mod_perl-internal? I am 
asking because no documentation is found for this module.

Anyway, if a previous version of my module is already installed then I get 
version conflicts between the xs and the pm parts while testing.

The reason is this line from XSLoader::load:

    my $modlibname = (caller())[1];

It obviously assumes that there is nothing in between in the caller chain.

But Apache2::XSLoader::load calls XSLoader::load as

    XSLoader::load(@_);

Wouldn't it be better to change this line to

    goto &XSLoader::load;

to make XSLoader happy?

Torsten

Mime
View raw message