perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David E. Wheeler" <da...@kineticode.com>
Subject Re: RELEASE CANDIDATE] mod_perl-1.31 RC1
Date Wed, 23 Jan 2008 18:29:45 GMT
On Jan 23, 2008, at 10:23, David E. Wheeler wrote:

> Makes sense for a mod_perl developer, of course, but personally I'm  
> usually building mod_perl to run Bricolage instances, so the static  
> compile has always made sense. The fact that the DSO builds are more  
> stable nowadays is great, of course. I'll give that a try.
>
> In the meantime, were you able to replicate the issue with a static  
> compile?

I just tried again without `--disable-shared=perl` and got the same  
build failure:

ld: warning in modules/perl/libperl.a, file is not of required  
architecture
Undefined symbols:
   "_perl_setup_env", referenced from:
       _handle_perl in libstandard.a(mod_include.o)
   "_perl_module", referenced from:
       _ap_prelinked_modules in modules.o
       _ap_preloaded_modules in modules.o
   "_perl_stdout2client", referenced from:
       _handle_perl in libstandard.a(mod_include.o)
   "_perl_call_handler", referenced from:
       _handle_perl in libstandard.a(mod_include.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [target_static] Error 1
make[1]: *** [build-std] Error 2
make: *** [build] Error 2

:-(

Ah, but it wasn't a DSO. So I switched to `--enabled-shared=perl` and  
tried again. That worked.

So it is something to do with the static build.

Best,

David

David


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message