perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fred Moyer" <f...@taperfriendlymusic.org>
Subject RE: [RELEASE CANDIDATE] Apache-Reload 0.10 RC3
Date Sat, 26 Jan 2008 05:19:18 GMT
>> Fred Moyer wrote:
>>> Greetings,
>>>
>>> Third time is the charm :)  RC1 and RC2 were missing
>>> t/conf/extra.conf.in from the MANIFEST.
>> [...]
>>> http://people.apache.org/~phred/Apache-Reload-0.10-RC3.tar.gz
>>
>> Fails all three tests here on WinXP/VC6 with perl-5.10.0, apache-1.3.39
>> and mod_perl-1.31 RC2 :-(
>
> Thanks for the spot Steve, I'll dig in and get this fixed.

Here's the problem, the first line in t/conf/extra.last.conf.in is

<IfModule mod_perl.c>

And here is the unix vx linux relevant apache_test_config.pm section [1]. 
Notice how Win32 doesn't have mod_perl.c, hence the IfModule is false, and
the location directives are not set.

I don't see a straightforward solution to this problem, if anyone has a
suggestion please bring it forth.  I can munge the Makefile.PL so that the
tests aren't run if $O is Win32, but would rather have the tests run.

[1]

Win32
               'modules' => {
                                'mod_include.c' => 1,
                                'mod_asis.c' => 1,
                                'mod_env.c' => 1,
                                'mod_negotiation.c' => 1,
                                'http_core.c' => 1,
                                'mod_setenvif.c' => 1,
                                'mod_access.c' => 1,
                                'mod_dir.c' => 1,
                                'mod_isapi.c' => 1,
                                'mod_actions.c' => 1,
                                'mod_cgi.c' => 1,
                                'mod_so.c' => 1,
                                'mod_alias.c' => 1,
                                'mod_imap.c' => 1,
                                'mod_autoindex.c' => 1,
                                'mod_auth.c' => 1,
                                'mod_log_config.c' => 1,
                                'mod_mime.c' => 1,
                                'mod_userdir.c' => 1

*nix
                'modules' => {
                                'mod_include.c' => 1,
                                'mod_asis.c' => 1,
                                'mod_env.c' => 1,
                                'mod_negotiation.c' => 1,
                                'http_core.c' => 1,
                                'mod_setenvif.c' => 1,
                                'mod_access.c' => 1,
                                'mod_dir.c' => 1,
                                'mod_cgi.c' => 1,
                                'mod_actions.c' => 1,
                                'mod_perl.c' => 1,
                                'mod_imap.c' => 1,
                                'mod_alias.c' => 1,
                                'mod_autoindex.c' => 1,
                                'mod_status.c' => 1,
                                'mod_auth.c' => 1,
                                'mod_log_config.c' => 1,
                                'mod_mime.c' => 1,
                                'mod_userdir.c' => 1


>
>
>>
>> C:\Temp\Apache-Reload-0.10-RC3>nmake test TEST_VERBOSE=1
>>
>> Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
>> Copyright (C) Microsoft Corp 1988-1998. All rights reserved.
>>
>> 	C:\perl510\bin\perl.exe -Iblib\arch -Iblib\lib  t/TEST  -clean
>> 	  C:\perl510\bin\perl.exe -Iblib\arch -Iblib\lib  t/TEST
>> -bugreport -verbose=1
>> C:/apache13/Apache.EXE  -d C:/Temp/Apache-Reload-0.10-RC3/t -f
>> C:/Temp/Apache-Reload-0.10-RC3/t/conf/httpd.conf -D APACHE1
>> using Apache/1.3.39
>>
>> waiting 60 seconds for server to start: .WARNING: StartServers has no
>> effect on Win32
>>
>> waiting 60 seconds for server to start: ok (waited 0 secs)
>> server localhost:8529 started
>> t\reload....1..3
>> # Running under perl version 5.010000 for MSWin32
>> # Current time local: Wed Jan 16 08:57:49 2008
>> # Current time GMT:   Wed Jan 16 08:57:49 2008
>> # Using Test.pm version 1.25
>> # Using Apache/Test.pm version 1.30
>> # writing file:
>> C:\DOCUME~1\shay\LOCALS~1\Temp\apache_test\Reload\Test.pm
>> # testing : Initial
>> # Failed test 1 in t\reload.t at line 39
>> # expected: const:const
>> # prototype:prototype
>> # simple:simple
>> # subpackage:subpackage
>> # received: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
>> # <HTML><HEAD>
>> # <TITLE>404 Not Found</TITLE>
>> # </HEAD><BODY>
>> # <H1>Not Found</H1>
>> # The requested URL /reload was not found on this server.<P>
>> # </BODY></HTML>
>> not ok 1
>> # writing file:
>> C:\DOCUME~1\shay\LOCALS~1\Temp\apache_test\Reload\Test.pm
>> # testing : Reload
>> # Failed test 2 in t\reload.t at line 47
>> # expected: const:CONST
>> # prototype:PROTOTYPE
>> # simple:SIMPLE
>> # subpackage:SUBPACKAGE
>> # received: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
>> # <HTML><HEAD>
>> # <TITLE>404 Not Found</TITLE>
>> # </HEAD><BODY>
>> # <H1>Not Found</H1>
>> # The requested URL /reload was not found on this server.<P>
>> # </BODY></HTML>
>> not ok 2
>> # testing : Unregister
>> # Failed test 3 in t\reload.t at line 53
>> # expected: unregistered OK
>> # received: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
>> # <HTML><HEAD>
>> # <TITLE>404 Not Found</TITLE>
>> # </HEAD><BODY>
>> # <H1>Not Found</H1>
>> # The requested URL /reload was not found on this server.<P>
>> # </BODY></HTML>
>> not ok 3
>> # removing file:
>> C:\DOCUME~1\shay\LOCALS~1\Temp\apache_test\Reload\Test.pm
>> # removing dir tree: C:\DOCUME~1\shay\LOCALS~1\Temp\apache_test
>> # removing dir tree: C:\DOCUME~1\shay\LOCALS~1\Temp\apache_test\Reload
>> FAILED tests 1-3
>> 	Failed 3/3 tests, 0.00% okay
>> Failed Test Stat Wstat Total Fail  List of Failed
>> ------------------------------------------------------------------------
>> -------
>> t\reload.t                 3    3  1-3
>> Failed 1/1 test scripts. 3/3 subtests failed.
>> Files=1, Tests=3,  1 wallclock secs ( 0.00 cusr +  0.00 csys =  0.00
>> CPU)
>> Failed 1/1 test programs. 3/3 subtests failed.
>> [warning] server localhost:8529 shutdown
>> [  error] error running tests (please examine t\logs\error_log)
>> NMAKE : fatal error U1077: 'C:\perl510\bin\perl.exe' : return code '0x1'
>> Stop.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
>> For additional commands, e-mail: dev-help@perl.apache.org
>>
>>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
> For additional commands, e-mail: dev-help@perl.apache.org
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message