perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@taperfriendlymusic.org>
Subject Re: Apache::Test - cannot find module 'mod_perl.c'
Date Sun, 14 Oct 2007 02:48:00 GMT
Geoffrey Young wrote:
> 
> Fred Moyer wrote:
>> I feel somewhat embarrassed to ask this question, but I've run into this
>> issue intermittently and haven't been able to find a deterministic
>> reason why this is happening.  I've been hacking on the sameinterp
>> changes for Apache::Reload and I can't get Apache::Test to load
>> mod_perl.so during 'make test'.  I've poked around the guts of
>> Apache::Test, added debugging prints where appropriate, and still no luck.
>>
>> Here's a summary of what's going on - hopefully I am doing something
>> dumb which is obvious to everyone but me.
>>
>> phred@harpua Apache-Test $ ls /home/phred/dev/sl/httpd2/modules/
>> httpd.exp  mod_perl.so
> 
> two things have to happen here...
> 
> the first is that your existing httpd.conf needs to contain a LoadModule
> line for mod_perl - because this isn't a mod_perl (proper) build, the
> only way Apache-Test is going to find mod_perl is just like any other
> module, via a scan of the httpd.conf pointed to via apxs or httpd

Ah ha - that did it!  I've been using an httpd binary for the app I 
spend most of my time on, and the httpd.conf in that conf dir is the 
default httpd.conf file.  This makes sense to me now.

Thanks for the help Geoff, much appreciated.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message