perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@taperfriendlymusic.org>
Subject Apache::Test - cannot find module 'mod_perl.c'
Date Sat, 13 Oct 2007 22:58:57 GMT
I feel somewhat embarrassed to ask this question, but I've run into this 
issue intermittently and haven't been able to find a deterministic 
reason why this is happening.  I've been hacking on the sameinterp 
changes for Apache::Reload and I can't get Apache::Test to load 
mod_perl.so during 'make test'.  I've poked around the guts of 
Apache::Test, added debugging prints where appropriate, and still no luck.

Here's a summary of what's going on - hopefully I am doing something 
dumb which is obvious to everyone but me.

phred@harpua Apache-Test $ ls /home/phred/dev/sl/httpd2/modules/
httpd.exp  mod_perl.so

phred@harpua Apache-Test $ perldoc -l mod_perl2.pm
/home/phred/dev/perl/lib/site_perl/5.8.8/i686-linux/mod_perl2.pm

phred@harpua Apache-Test $ make test
make[1]: Entering directory 
`/home/phred/dev/svn/modperl/Apache-Test/Apache-TestItSelf'
make[1]: Leaving directory 
`/home/phred/dev/svn/modperl/Apache-Test/Apache-TestItSelf'
/home/phred/dev/perl/bin/perl -Iblib/arch -Iblib/lib \
         t/TEST  -clean
setting ulimit to allow core files
ulimit -c unlimited; /home/phred/dev/perl/bin/perl 
/home/phred/dev/svn/modperl/Apache-Test/t/TEST -clean
APACHE_TEST_GROUP= APACHE_TEST_HTTPD=/home/phred/dev/sl/httpd2/bin/httpd 
APACHE_TEST_PORT= APACHE_TEST_USER= 
APACHE_TEST_APXS=/home/phred/dev/sl/httpd2/bin/apxs \
         /home/phred/dev/perl/bin/perl -Iblib/arch -Iblib/lib \
         t/TEST  -bugreport -verbose=0
setting ulimit to allow core files
ulimit -c unlimited; /home/phred/dev/perl/bin/perl 
/home/phred/dev/svn/modperl/Apache-Test/t/TEST -bugreport -verbose=0
looking for module mod_mime.so
looking for module mod_alias.so
/home/phred/dev/sl/httpd2/bin/httpd  -d 
/home/phred/dev/svn/modperl/Apache-Test/t -f 
/home/phred/dev/svn/modperl/Apache-Test/t/conf/httpd.conf -D APACHE2
using Apache/2.2.4 (prefork MPM)
waiting 60 seconds for server to start: ok (waited 0 secs)
server localhost.localdomain:8529 started
adding source lib /home/phred/dev/svn/modperl/Apache-Test/lib to @INC
adding source lib /home/phred/dev/svn/modperl/Apache-Test/lib to @INC
adding source lib /home/phred/dev/svn/modperl/Apache-Test/lib to @INC
adding source lib /home/phred/dev/svn/modperl/Apache-Test/lib to @INC
t/alltest/all............skipped
         all skipped: testing all.t
t/alltest2/all...........skipped
         all skipped: testing more than one all.t
t/bad_coding.............ok 

t/cookies................skipped
         all skipped: cannot find one of cgi or cgid
t/more/all...............skipped
         all skipped: cannot find module 'mod_perl.c'
t/next_available_port....skipped
         all skipped: cannot find one of cgi or cgid, cannot find module 
'mod_env.c'
t/ping...................ok 

t/redirect...............skipped
         all skipped: cannot find module 'mod_alias.c'
t/request................ok 

t/sameinterp.............skipped
         all skipped: cannot find module 'mod_perl.c'
All tests successful, 7 tests skipped.
Files=10, Tests=13,  4 wallclock secs ( 3.73 cusr +  0.41 csys =  4.14 CPU)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message